Token Sale Voucher Registration help thread

Is anyone else receiving this message when registering?
Do you mean to switch apps?
Microsoft edge is trying to open “Protocolhandler”?

Hey @suesue,

What’s supposed to happen when you sign in is you’ll be redirected to the Blockstack browser. It looks like this isn’t happening for you.

Tagging @aaron to see if he knows how to fix this.

I know. It’s been crazy. Actually speaking with support as well. After trying on 5 different computers it’s starting to wear me down… but not giving up yet!! Lol

We define a custom protocol handler to handle authentication requests – it handles blockstack:// style URLs.
The protocol handler on Windows can sometimes get a funny name – I’m not sure why exactly, but I’m pretty sure it has something to do with The Windows Registry. Anyways, yes, you should open the authentication request protocol handler.

The protocol handler itself opens a URL like https://localhost:8888/auth?authRequest=<foo> in your default browser. If your default browser is Edge, you get the window in Edge. However, if you’ve set up your Blockstack profile in Firefox, you might want it to open there instead. You can copy and paste that URL into Firefox in that case, or go and change your default browser to Firefox (it’s in Windows account settings).


I am downloading Firefox on 2 laptops now. Will let you know what happens. I am pulling out my hair!

It worked!! But now nothing is being verified!!!

Verified. Wow. That took 3 days!


I applaud your persistence! But that’s great news, were you also able to register then now? Got the confirmation email?

YES!!! I would suggest using Firefox and not I.E. that was the main problem. Twitter was a quick confirm, but FB and LI were impossible, so I signed up for Github and followed the instructions. I am not computer savvy by any means, but 3 days and about 8 hours of trying finally paid off. I worked with this forum and the support group to get this done. My only question is … after days spent registering… will I be able to purchase tokens? That’s the million dollar question. :slight_smile:


If you click the Blockstack explorer link on your verifications, it will say which ones worked, and you can check if things are stored correctly there (like your name etc).

FB and LinkedIn are trickier as you doubtless has seen in the guides on this forum. They are not open-by-default. I haven’t even tried those yet. But might try to get a full profile again.

Thanks for the info!! I’ll try a few more. Was just happy to finally get verified and on the site properly. The email arrived right after Inregustered and will play around with it some more later today!


Hey @suesue, I’m glad you got it working :tada: Thank you for being so patient with us!

I have downloaded and install the Blockstack browser, provided my Facebook and Twitter IDs, my Bitcoin and Ethereum wallets. But I have tried severally without success to verify my Facebook and Twitter accounts, therefore, I cannot complete my token reservation with less than 48hrs to the end of registration.

My Facebook user name is: Udukormoh Phil, and my Twitter ID is: @SMphil4christ

I will appreciate it if this is resolved quickly to enable me participate in the token sale registration.

So your address is 15H6dCYVNutycFJdK3F7t6QEmfZajX6WuJ from

However, I can’t find your registration on Gaia. Did you use the standard storage provider? How did you do your steps? What OS, what browser?

This is his info.

1 Like

So your twitter ID is wrong, it should not be with a space at front, it should also not include the @.

The Facebook url looks wrong, it should be nicer than that. Also the identifier is likely wrong too, I don’t think you can have a space in the ID. It would either be like “odin.omdal” or it would be a number IIRC. Check the howtos.

Hopefully updating this should fix it :slight_smile:

Thank you @odinho, your advice was quite helpful and I have been able to verify my twitter account. However; I have also done all you suggested with regards to the Facebook account verification and am still not able to resolve it. I even deleted the initial post and did a fresh post and verification without success.

Please see the details again and help me identify the problem:
Username: udukormoh.phil

Thank you for your assistance

I can’t figure out how to get back to My ID Page to confirm my social networks. When I first did so, they did not go through, and now I cannot find how to sign in to update it!

And it will not let me register to buy tokens without it…

Hey @carmenreynal, sorry to hear you’re having trouble!

Can you post your ID-address from your identities page? I can use it to check your social proofs. Thanks!