Recover Password

I updated my Mac BlockStack app, and I was basically forced to recover my whole account in order to login.
So, I had my blockchain key phrase, and I entered it, but then it asked for my password. And I’m stuck at this step, because I don’t remember my password, and I can’t recover it because there is no way to recover it. Any ideas what I need to do to re-access my account?

It’s a new local password to use, not your old one =)

The Browser only needs your Key Phrase in order to recover your account; the password entry is simply to lock it down again within the new instance, so to speak.

@bgbs Hi Benji, if you go through the sign-in flow and restore your existing Blockstack ID, you should be able to set a new password.

This is all bollux’d up. I have a passphrase and an id ( and, now, 4 different passwords to use “from when you created your id” and NONE of these passwords work. I even changed my password before resetting the browser, and the new one doesn’t work. The “sign in flow” does NOT allow a new p/w to be associated with my id (pass phrase) and email, thus, it looks like I need to abandon (forever?!?) my id b/c I can’t use my password or reset it?

Sorry, but wtf is wrong here? The browser app (local:8888) seems broken. Oh, and I am using Safari. i want to switch to Chrome (b/c Safari doesn’t work for apps like Coins), but I can’t LOGIN ON CHROME. Holy smokes, this is SO frustrating!!

So, I just (somehow) opened BS via Safari, changed the password, etc. and accessed Graphite (=all’s working), but I STILL cannot switch to BS via Chrome b/c I can only enter passphrase and email, but SOMEHOW can’t use the SAME p/w that works in Safari (Give “The password you entered when you created this Blockstack ID.”). If it’s “unique to safari” then shouldn’t I be asked for a new p/w? If it’s not, then why can’t I reset the p/w when I have my passphrase? /frustrated.

Hi David, if you want to restore your Blockstack profile in a different browser, i.e. Chrome, you will have to go through and provide the 12-word passphrase you saved when you created your Blockstack ID. After entering your passphrase (in the first screen) and email address (in the second screen), you can set a new password in Chrome (in the third screen).

Thanks for the reply Sebastian, but I do NOT get a “reset p/w” screen. Instead, it asks for my p/w.


Any idea of how I can trigger a “new p/w”?

(btw, I cleared all data/cookies and still it asks for p/w)

Thanks for the response, David. The screen mentioned above gets shown when you enter the “Magic Recovery Code” that was sent to you via email after registration.

To restore your keychain in another browser and set a new password, you will need to enter your 12-word mnemonic passphrase (consisting of 12 individual words). Did you save this passphrase when you first registered?

Alternatively, if you are still logged in in Safari, you can retrieve it when you go to Settings > Backup Keychain (http://localhost:8888/account/backup). You can then use the 12-word passphrase to restore and set a new password in Chrome.

Hi Sebastian – I have both the magic code and my 12 words. No matter which one I use (under “restore you r blockstack ID”), I get “enter email” and THEN “enter p/w”

I cannot seem to get to a reset p/w screen.

The only way to set a new p/w is to get a new blockchain ID (replacing, which i don’t want to do :frowning:

Thanks, David. Unfortunately, I’m not able to reproduce this issue. You may get prompted to enter your current password because a password has already been set. Have you tried resetting your browser via Settings> Reset Browser (http://localhost:8888/account/delete) and restoring with your 12-word passphrase?

Yes, I have a p/w for the Safari “session” that I can use to login and modify Graphite docs. I want to create a new session in Chrome, and have no p/w there. When I delete cookies and quit BS and then open a “new session”, it launches Chrome and takes me to Create a BS ID, etc.


Entering that url (/account/delete) does not make any difference :frowning:

When you get redirected to http://localhost:8888/sign-up, there should be an option to restore as well (http://localhost:8888/sign-in):

If you are not able to go through this flow, I recommend doing a hard refresh in Chrome and reinstalling Blockstack, then restoring from backup via http://localhost:8888/sign-in.

Yes, that’s the exact page I see… then I add my passphrase, it asks email, then “what’s your p/w” which it will NOT accept. (Not sure if the p/w is for a local login or is for my id!)

ps/I’m still able to use BS on Safari (open/save docs, etc.) but cannot open a new session in Chrome. It’s a bit ridiculous.

If I delete the app, clear all data, etc., will I be able to use my NOW WORKING p/w in Safari? Or is there no p/w reset? I have my passphrase, of course.

Can you tell me, btw, if my p/w is for my BS id or a local browser session? Would I have different p/ws for different browsers?

What’s CRAZY is that I can enter the p/w to see my passphrase on the local install, via Safari:

I can’t use the SAME p/w to login via Chrome or via the browser (, which is REALLY confusing!

Anytime, David, happy to help. To clarify, the password you set in Safari is a local password. To restore your ID in a different browser (i.e. in Chrome) and set a new password, you will have to restore from backup with your 12-word passphrase.

If you are not able to restore and set a local password in Chrome, a hard refresh, reset, or reinstall should help to go through the restore flow, either via the Blockstack app or the browser.

ok, and just to clarify, if I log-in via the browser (from any app), how do I set a new p/w? It’s asking me for a p/w. If I go for a new p/w then it wants to create a new ID. Kinda confusing…

If you reset your browser in Chrome and go through

a.) http://localhost:8888/sign-in (as opposed to http://localhost:8888/sign-up) -or-
b.) (as opposed to

you will be prompted to

  1. Enter your 12-word passphrase connected to your ID.
  2. Add an email address.
  3. Create a new password.

I just ran through the restore flow after resetting my browser and the flow works fine on my end.

It’s still not working (asking for a p/w) :frowning:

I don’t get it. I’ve NEVER logged in via chrome, so there should be no p/w, but it keeps asking, even after I reset. this is so frustrating!

Can you do a call?

ps/the dialogue is “The password you entered when you created this Blockstack ID.” so that’s a p/w on a server somewhere, right?

If not, then the dialogue should ask me to create a new p/w for the local instance, as there is no local p/w. If so, then it’s not decentralized, right?