Recover Password

pps/login via browser (which should use a p/w on a remote server) also asks for a p/w that I’ve never used (or disagrees with the one I do use), so I also cannot log-in

ppps/is this perhaps a problem with the version? Your public (stable) release is 0.29.3, but now 0.30.0 is in alpha. Are p/w’s or user names handled differently?

Thanks for trying that, David. I went through the flow to restore my ID, and everything worked fine on my end. There may be a misunderstanding about how this flow works. To recap, please try to do the following:

  1. In Safari, save your 12-word keychain phrase (Settings > Backup Keychain)
  2. In Chrome, do a hard refresh / clear your cache
  3. In Chrome, go to
  4. Enter your 12-word keychain phrase (Screen: “Restore your Blockstack ID”)
  5. Enter your email address (Screen: “What is your email address?”)
  6. Create a new password (Screen: “Create a password”)

This flow will restore your Blockstack ID in Chrome and set a new password. If this is not working, feel free to reach out to [email protected] with screenshots, and we can troubleshoot further.

One last thing:

Is there a difference on this issue (new vs existing p/w) in these different builds? If not, then I prefer to use the stable (0.29.3) build. But you tell me ?

There is no difference in password functionality. The 0.30.0 build includes the ability to register sponsored usernames after sign-up as well as some bug fixes.

Ok, now I’m totally screwed: I now cannot log-in via any method (Safari used to work.)

I suggest that BS’s id model is broken, as I have may passphrase as well as the magic code BUT there’s still a p/w for the .id that I can’t seem to find. I used one locally w Safari, but “reset account” (delete local install), and thus – I guess – deleted my one working access point for BS. I guess that also means I have permanently lost all data related to my

This is a fatal design flaw, as it makes no sense to add a p/w on top of a passphrase that CANNOT BE CHANGED OR RECOVERED!

What’s left to me? Start again, I guess? (Oh, and the irony is that I think I’m now logged in via BS to this site but will not be able to login again… Let’s see…)

I’m logged in via github, not BS, which I now appear to be permanently locked out of :frowning:


I have no idea how it happened, but my copy/paste of my passphrase dropped one word. I was trying to use 11 words to recover! When I used the “magic phrase” and original p/w (this needs to be emphasized more, as the difference between .id p/w and “local instance” p/w is really important!) and was able to login.

When I created a new instance on chrome it DID ask for a new p/w, so that worked as Sebastian had suggested.

So, advice: (1) drop “give original p/w” and let people recover with passphrase/magic key only
(2) tell users when they give [pass phrase != 12|24] so they can not make that mistake.

All good now. Whew! =D

David, I’m glad the suggestions to restore your ID and set a new password helped. Thank you for your feedback regarding the on-boarding/recovery flow. CC @jeffd @yukan

We’re now tracking this as an issue in the blockstack-browser repo, and I’ll see if it can fit into this sprint. Thanks again David!

Please Sebastine, what if you don’t have the correct 12-word keychain phrase, is there a way to recover your account?