I had registered (and confirmed) several .id namespaces via and it now appears I do not own any of those name spaces. When I search for the ids via (, they are either unregistered or now owned by somebody else!

What is going on here???

1 Like

Because this shit doesn’t work…

I tried a couple months back. I needed to keep my computer open for it to fully register. If I didn’t or if I lost my connection it would cancel that registration and it cancelled. I didn’t get a refund either.

So as far as I’ve seen, they’ve done a good job marketing but not a good job building the tech. I just came back to see if they have fixed stuff and their proposed newly added apps. I still don’t see any future for this project. I will continue checking it out every now and then…

Have either of you tried to email [email protected] and explain your issue to them? I’ve seen a few other people on here have good success when they take that route. If you haven’t give it a shot and see if that can help you with your usernames.

Having the same problem. I’ve registered a username and yesterday I’ve signed into my Blockstack account after a couple of weeks and noticed that I don’t own my ID anymore.

Yep I’ve emailed them, talked with them. They are good at responding & nice people. I liked their support. Unfortunately this doesn’t make their tech is user friendly.

Did you manage to solve the issue in the end or is your username lost?

It was lost. And so was the money I sent for the username. I didn’t try it again. Not until I know for sure that their tech works.

1 Like

I reached out to support and have heard nothing back…

I’m sorry we haven’t gotten to your query. A number of team members were on vacation over the last couple of weeks and our response time has been slower than normal. We will get to your query soon!