What Should Happen After Clicking "Sign In With Blockstack"?

The page refreshes and then… nothing. It does this for the To Do list and Hello.

@ToddStarbuck If you are logged in with your Blockstack ID, you should be able to sign into any app in your browser. Have you tried hard-refreshing your browser, or restoring your keychain?

I’ve only tried refreshing the window. I don’t know anything else about trouble shooting blockstock, so I don’t have a list of things to try.

How do I restore the keychain?

Does it matter what browser I’m using to open the blockstock browser? I’ve been using FireFox.

@ToddStarbuck To restore your keychain, first make sure you have your 12 word passphrase. You can back it up in Settings > Backup Keychain. To restore, you can go to Settings > Reset Browser.

Also, please be sure to update to the latest browser release. Once you have restored your keychain, try to sign in with your Blockstack ID. It shouldn’t matter which browser you use as your default browser.

1 Like

I will try those steps as soon as I can. Thanks.

I did all that. Same result.

Nothing happens after I click “Sign In…”.