Unable to login

Hi, I recently created a blockstack account so that I could start using bitpatron. It seemed to work ok but then I kept getting the following message:

Your blockstack account is invalid - no username loaded. Please reset your blockstack account and try again.

I got the blockstack welcome email with the magic recovery code and a link to the secret recovery key. When I clicked the link to the secret recovery key I just got the above error again.

bitpatron support suggested I reset the browser by going to Settings -> Reset Browser.

On attempting to log back in I discovered that Safari hadn’t saved the strong password it generated for me. I’m now locked out of the account and don’t have the 12 word recovery phrase at I was unable to get it before due to the error above. Is there anything I can do?


Hi @aloysius, I’m afraid that if you didn’t save your password or the 12-word recovery phrase, there’s no way to access your account.

Do you have a sense of how or why Safari failed to save that strong password? Perhaps there’s something we can do to help guarantee that in-browser password managers save the password value consistently.

@aloysius I would like to open a github issue for this problem and see if I can reproduce it. Please fill out the information below including your GIthub Handle and we will create a github issue for your problem and @mention you in the issue so we can make sure we get this resolved.

Please Enter Your Github handle

Describe the bug
A clear and concise description of what the bug is.

To Reproduce
Steps to reproduce the behavior:

  1. Go to ‘…’
  2. Click on ‘…’
  3. Scroll down to ‘…’
  4. See error

Expected behavior
A clear and concise description of what you expected to happen.

If applicable, add screenshots to help explain your problem.

Desktop (please complete the following information):

  • OS: [e.g. iOS]
  • Browser [e.g. chrome, safari]
  • Version [e.g. 22]

Smartphone (please complete the following information):

  • Device: [e.g. iPhone6]
  • OS: [e.g. iOS8.1]
  • Browser [e.g. stock browser, safari]
  • Version [e.g. 22]

Additional context
Add any other context about the problem here.

I’ve no idea why Safari failed to save the password. It’s puzzling - I would have assumed that Safari would save the password when the form is submitted? I’m happy to just start another account as I hadn’t done anything with that one.

Yea I would have assumed the same. I’ll keep my eye out during user testing to see if I see this issue crop up generally. I’m glad you’re able to create a new account in this instance.

I’m not sure if the issue is one clearcut problem - there was the issue of Safari not saving the strong password, and also the issue of the error message “Your blockstack account is invalid - no username loaded. Please reset your blockstack account and try again.” I don’t know if both issues are related? I tried starting again, using chrome this time just in case it was a browser based issue, and the user name I used before was again listed as available. Once again I got the “Your blockstack account is invalid - no username loaded. Please reset your blockstack account and try again.” message. This time I manually recorded the password and was able to keep access to the account.

UPDATE - I just tried signing in and again I’m getting the above error message.

UPDATE - I tried starting again this time using firefox. I went straight to browser.blockstack.org to create the account rather than going through bitpatron.co. The username is again coming up as available, but on entering the name I am getting a popup stating “Username Registration Failed Sorry, something went wrong while registering aloysius.id.blockstack. You can try to register again later from your profile page. Some apps may be unusable until you do.”

Thanks for the information @aloysius. What is your Github handle?

Github handle is AloysiusLeeson

Thanks for bringing this problem to our attention. I have create github issue https://github.com/blockstack/blockstack-browser/issues/1918 for this bug and added your Github handle to the ticket. We will resolve this problem shortly, for now please manually save your password in safari, sorry for the inconvenience.

1 Like

Whenever I attempt to login with my block stack ID using the safari web browser on my iOS, it fails to authenticate. I tried 5-6 times but failed. It seemed to me that my safari can’t verify the identity of the website. I need your help.

Are you getting an SSL certificate error in Safari specifically? Could you provide a screenshot of it?