Unable to get started

Hi, I think Blockstack looks interesting and wanted to try it out. I then ran into multiple problems & errors when trying to get started; here follows a question (item 1) and some problems (the other items) you might be interested in:

  1. when I try to login, a dialog appears: “Search for your username”. I don’t understand. Do I have a username? Where? Why shall I search for it? Below, there’s a grayed out disabled text input, where I cannot type anything. I can do something with Onename, which I’ve never heard about before. The only makes-sense thing to do is to click Cancel, which apparently prevents me from logging in with Blockstack. So I’m stuck. There’s no continue button, and I don’t have any Onename name, and I cannot type in the disabled text input.

  2. A bit earlier I attempted to get started via the browser. I just wanted to test, so I created a new Hacker News account and tried to verify it. That did not work, Blockstack couldn’t verify it.

  3. Then I attempted to verify a Twitter account, and tweeted. Accidentally a private tweet. Then I changed the tweet’s status to Public, and verified in an incognito browser that it’s indeed public. Still, Blockstack cannot verify it.

  4. When running Blockstack via Docker on localhost Linux, I’m getting an error and the script seems to exit & die, look at the very last line here:

19:31:51 10 ~/app$ sudo ./Blockstack-for-Linux-v0.21.4.sh start

Please enter a password to protect your Blockstack core node.
IMPORTANT: This will be used to encrypt information stored within the containers
           which may include private keys for your Blockstack wallet.
           It is important that you remember this password.
           This will be the password you use to "pair" your Blockstack Browser
           with your Blockstack core node.

           Legal characters:
               letters (upper and lowercase), numbers, '_', and '-'

Wallet does not exist yet. Setting up wallet
Saving configuration to /root/.blockstack/client.ini
Wallet is encrypted using your password and stored  at "/root/.blockstack/wallet.json", please make sure you create a backup.
    "status": true
Re-exec as `"/usr/bin/python", "/usr/local/bin/blockstack", "api", "start", "--secrets", "3"`
[2017-12-27 18:32:12,367] [DEBUG] [spv:103] (11.139845448197888) Using mainnet
[2017-12-27 18:32:12,449] [DEBUG] [cli:419] (11.139845448197888) Load secrets from 3
[2017-12-27 18:32:12,483] [DEBUG] [client:95] (11.139845448197888) Connect to https://node.blockstack.org:6263
[2017-12-27 18:32:12,486] [WARNING] [storage:632] (11.139845448197888) Storage implementation is missing a "get_immutable_handler" method
[2017-12-27 18:32:12,487] [WARNING] [storage:632] (11.139845448197888) Storage implementation is missing a "put_immutable_handler" method
[2017-12-27 18:32:12,488] [WARNING] [storage:632] (11.139845448197888) Storage implementation is missing a "delete_immutable_handler" method
[2017-12-27 18:32:12,489] [WARNING] [storage:632] (11.139845448197888) Storage implementation is missing a "delete_mutable_handler" method
[2017-12-27 18:32:12,606] [WARNING] [dropbox:188] (11) Config file '/root/.blockstack/client.ini': section 'dropbox' is missing 'token'.  Write access will be disabled
[2017-12-27 18:32:12,607] [DEBUG] [client:110] (11.139845448197888) Loaded storage drivers ['disk', 'gaia_hub', 'dropbox', 's3', 'blockstack_resolver', 'http', 'dht']
    "status": true
Registering protocol handler
[14767:14767:1227/193218.198350:ERROR:zygote_host_impl_linux.cc(88)] Running as root without --no-sandbox is not supported. See https://crbug.com/638180.
  1. To me it’s a bit confusing with 3 different password/passprhases. First, there’s something I need to type in Bash. Then I select a password in the browser, and then lastly I get shown a passphrase. … A bit later, Blockstack asks me to enter the password in the browser — which of those 3, I was wondering. Apparently I typed the correct one.

Right now the situation is that I’m trying to use some BlockStack app, and there’s this dialog:

Sign In Request
The app "Todo App" wants to access your basic info
You need to set up Blockstack in order to sign in.

but I don’t know how to setup Blockstack. I have created an ID, specified my name, verified my Twitter account (that worked, when I tested again with another account). Don’t know what more to do.

I’m posting this, because I know from experience that info about what different problems people run into when they try to sign up, can be valuable. I think this project looks interesting and it’d be interesting to try it out. What if you somehow created light-weight test account so people can try out Blockstack without running into lots of problems and … maybe giving up?

I hope this is useful & helpful info to you, & kind regards,