Unable to Add Username

I have been unable to get blockstack to accept my username and thus been unable to register.
I already sent the bitcoin payment, but am unable to progress my registration due to this issue.
I have my twelve word sequence saved, but I’m unsure as to where I can use this to reset the password.
Please advise… Thanks

Hi! You can register without a name. You only need minimum one verification.

OK thanks! I’ll try that and then see if I can secure my username

Hey @12QnPRUD7EYq7PSPFcm3,

It takes a couple hours for the name to be registered. Blockstack will issue two Bitcoin transactions in the background, and it will wait for the first one to be confirmed before sending the second one. You need to leave your computer online during this time for it to go through. You can check its progress using any Bitcoin block explorer by inputting your wallet address, and you can confirm whether or not it is registered by searching for it at explorer.blockstack.org. Hope this helps!

Hi Jude,
Thanks for sharing that. I’ve been able to progress to (a) validate my profile on Github and (b) I see the Bitcoin has arrived on my Blockstack account.
The nub of the issue for me right now is this; Blockstack won’t accept my password, so I can’t do anything on the system requiring a password. To change the pwd, I need the original one, but it won’t accept it.
I do have a copy of the Keychain Phrase, but don’t see how I can use this to reset my password!

Best Regards,

Hey @12QnPRUD7EYq7PSPFcm3,

If you forgot your password but still have your 12-word recovery phrase, can you try the following?

  • Clear your localStorage from the developer console (or open an incognito window)
  • Open the blockstack browser. You will be prompted to re-do the onboarding steps.
  • When you re-do the onboarding steps, you’ll have the option to recover from a 12-word passphrase. You should take that option.
  • Once you input your 12-word passphrase, you will have recovered your name and profile.

It may take a few minutes for the data to arrive in the browser (a known issue we’re investigating), but as long as your ID-address matches the address of your name in the explorer, you definitely own the name!

I paid for an ID but it wasn’t linked to my new username. How can I link it?

Can you share some more details? A link to the name in the blockstack explorer as well as the ID that you are trying to register the name to would help.

However, first I would try a hard refresh of your browser. That helps most issues like this.

I am having similar issues after installing Blockstack Browser and trying to get all of my account details setup in the “Complete your ID” user flow.

  1. Installed Blockstack Browser (Mac)
  2. Setup my real name, bio, 5 account verifications (git, twitter, hackernews, btc address, eth address)
  3. Began (never able to complete) attempting to create my .id by:
    3a. send BTC to my wallet
    3b. tried to purchase my .id but received the attached error

Error descriptions:

  1. Name registration failed without a clear reason why.
  2. After this failed, all of my account verifications were wiped

I tried this twice in a row and now my verifications were wiped again. Hope this is helpful and I can successfully register my name soon!

forgot to attach screenshot.

Kevin. I’m having precisely the same issue. All my social verifications and my photo completely cleared and I reestablished everything by resetting the browser and re-doing everything. I seem to be back in business now but I’m concerned about trying to register a new username. Has this issue been resolved for you yet?


I am trying to add a name from Onename but after I enter my password on the onename.com site, it says it can take to 48 hours and its been almost a week,

I have tried to watch the transactions linked to the Bitcoin address of my Blockstack account but none is visible yet.
Here is the name on onename: https://explorer.blockstack.org/name/hamady.id
And here is my address on Blockstack: 1JxnssvZHgj6pz8JimFgkh4LFbiEeTqTge


@1JxnssvZHgj6pz8JimFg It looks like https://explorer.blockstack.org/name/hamady.id has been renewed for ID 1KH7J47F9YcLckxeSLpJEapn46rXF2M1h3 at block 493492, which is why the transfer has not been successful. Do you own this address in your browser?

Thanks you for your answer.

I can see here https://explorer.blockstack.org/address/1KH7J47F9YcLckxeSLpJEapn46rXF2M1h3 that this address owns the ID but I don’t know why I dont see the address in my Blockstack.

I completed the migration from onename to blockstack a couple of months ago but at one point, my Blockstack was bugged, I did a force reset and entered my passphrase I was expecting to retrieve my name but did not.

Now I no longer own the address 1KH7J47F9YcLckxeSLpJEapn46rXF2M1h3