Trouble registering an id using the browser on a Mac

So, I have an account, a proposed name, and a price. But when I try to go forward I wait 36 hours at

‘Generating Registration Transactions’

The blockstack explorer is not showing anything for the name. I am guessing the process has failed. This is with a most recent blockstack browser, a Chrome browser, and there is about 3 times the required bitcoin in the wallet. It is on VPN, the browser has been left open, and the Mac should not go to sleep.

Am I a total klutz? (Well, the answer to that is ‘yes’, but what should I do to register?)

This may help - Please try to hard refresh your browser and be sure to keep it open while the transaction is processing.

Thanks for the suggestion. I have tried it several times, even with browser 0.23.0 and it does not seem to be helping me. Thus far, I have gone through I think four several hour waits and all I have to show for it is that the price for the name sought has gone up 4 times. [It hangs at ‘Generating Registration Transactions’.]
There are some other details, which unfortunately I do not know enough to interpret properly. I have tried to do the Blockstack tutorials and I have, separately, tried to run Blockstack in a regtest test environment. I believe everything I have started I have stopped, and environments have been deactivated. Kitematic seems to show some Blockstack ‘components’ running in docker (and I do have docker running)

and, occasionally, I have stopped these from Kitematic. I do not know what starts them (I don’t on purpose). When they are running usually I cannot log in to an application. The Mac Activity monitor just shows

which I think is right.
Basically it is all a little beyond my level of comprehension.

Hi, this may help you: “If you want to buy a name with your wallet empty the process is a little more complex because the transfer can take a long time and the process will seems frozen, so I recommend to supply your wallet before” take a look at: How do I create a Blockstack ID?

Thanks for the suggestion. But I have a fully charged wallet (0.0055 bitcoin trying to buy a name that (now) costs 0.0020740000000000003), and I knew of the link you recommended and was following it step by step.

Hi, I’m sorry that it has not worked, I’m not an expert and Blockstack team usually resolves this type of problems in the forum but you can contact them at [email protected], so if you have time, you can try to restart everything.

1/ Go to Blockstack Settings.
2/ Settings: Backup keychain (keep it as your life).
3/ Settings: Reset Browser.
4/ Clear Chrome browsing data.
5/ Restart computer.
6/ Launch Bolckstack and restore your account via your keychain.
7/ Try add and buy your username.

“Success consists of going from failure to failure without loss of enthusiasm” Winston Churchill


1 Like

So, I seem to have succeeded in buying a name. I can describe the steps, but I cannot give an explanation of what caused it to work this time and prevented it from working before. Maybe this post will help someone.
The Blockstack browser itself was updated, after failures but before success, to 0.23.0.
I restored the account from the Backup keychain.
I used Kitematic (a GUI for docker) to stop the blockstack test environments.
Then the purchase just went through. It was only minutes at ‘Generating Registration Transactions’ then a few hours, or more, before it succeeded.

I still don’t know what on my machine is starting the docker blockstack test environments when the machine restarts. Docker can do this, so can many other things. I’ll post again if I gain understanding.

I have subsequently bought another name for a separate identity. It went through without a hitch in about an hour or so. Whatever had been causing me trouble seems not to be doing so now.

1 Like