registration problem


Couple of times i tried to register my STX name but every time failed. I tried 4 times and every time it took me 2 STX but registration failed at the end. What am i doind wrong? My wallet:

One of many fails: Function call (Failed) - Stacks Explorer by Hiro

Last fail:

In that particular example, it’s because you already submitted an identical name-preorder recently. Do you have any of your attempts to register the name on-hand?


This is the first attempt.

What could i do to register name sucesfully?

1 Like

The error message seems to suggest you tried to register an invalid name:
(define-constant ERR_NAME_CHARSET_INVALID 2022)

Did the name include any character aside from a-z, 0-9, dash or underscore?

I found that both the site and the BNS contract allows to pre-order an invalid name. However, the BNS contract prevents the succeeding registration transaction from completing successfully, rightly so.

I think the UI, in this case, should prevent the initial pre-order.

1 Like

Are you trying to register ‘Barry’?
BNS contract only allow lower case letters(i.e., a-z, 0-9, _, -), so you should register ‘barry’. However it has been registered by others.

1 Like

Thank you for answer!

1 Like

You can now own a handle in your favourite crypto community. Currently, we support :point_down:


1 Like

Why the .id is not including?