Stuck in a login loop

Hello all -

I’m having trouble logging into the Blockstack Browser. I’m caught in the same loop, and have run it enough times to make a Google Slides with what happens.

Thanks for any help you may have! I’m super excited to use Blockstack, an enthusiasm that has kept me at this issue despite it being so frustrating.


1 Like

@kkennett Hi Katrina, I’m sorry you’re running into issues when trying to log in. There are a couple things that have been fixed in our latest release, including the verification issue you mentioned.

Please try to update your browser to v26.2 to see if this resolves the issue. If you continue to have trouble, feel free to reach out to [email protected] and we can troubleshoot further.

@sebastian thanks for your quick reply!

On thelatest release (26.2) post, there is just a .dmg file for Mac OS. When should I expect 26.2 for Windows?

I scrolled down to the 26.1 release and just downloaded the Windows file for that.

Friendly question: when will reflect the latest releases? It is currently linked to the 26.0 releases.

Thank you!

Thanks Katrina! You are correct, v26.1 includes the latest update for Windows while we just released v26.2 for MacOS. The fixes for Windows, MacOS, and Linux were included in v26.1, so this should resolve the issue.

We are currently working on updating the website and the releases section should soon be updated as well to match Github. Thank you for pointing this out!

1 Like

Hey Katrina,

I feel like you have probably already tried this, but just to be sure, have you tested this in another browser? It looks like you are using Firefox (which should be fine), but if you have success with another browser, maybe that will narrow things down?

1 Like

@jehunter5811- I actually hadn’t yet tried it in another browser, but did this morning, and it’s currently working in Chrome. But, still not in Firefox. @sebastian perhaps this is informative? Glad to have it up and running at least!

Thanks for your help, both of you,

1 Like

@kkennett Glad you were able to log in via Chrome, Katrina. Thank you for your feedback, I’ll pass this on to our engineers. Please let us know if you continue to have any issues.