Stacks testnet

Hey Blockstackers!

Today we’re proud to announce the release of our public Stacks testnet! The Stacks testnet represents a significant milestone on the path to releasing the Stacks token system—most of the token infrastructure is written and working. You can access the testnet at

On the Stacks testnet, developers can experiment with:

  • Sending and receiving Stacks tokens
  • Buying names and namespaces with Stacks tokens
  • Registering subdomains
  • Using our new Blockstack command-line tool

The testnet is made of fully functional Blockstack Core nodes, and lets you do all the same things you would do on mainnet. The differences are that it uses testnet tokens (the testnet website can give them to you), and the block time is 1 minute instead of 10 minutes.

If you’re a developer or power user who wants an early glimpse of the token system, go grab the new CLI tool and start hacking! If you find any bugs, please let us know.


Really excited to see this live! The testnet is a major step towards pushing the first version of the new blockchain live. For anyone wondering about Milestone 1 from our token sale, yes this is significant progress towards meeting that milestone.


So is the plan with Stacks to stop using Bitcoin as the underlying network and switch to our own network?

We’ll still be using Bitcoin to secure the Stacks chain. Long-term, only Stacks miners will need to interact with Bitcoin (through proof-of-burn mining) in order to append new Stacks blocks. Users will only transact in Stacks, and will send Stacks transactions through the Stacks network so Stacks miners can pick them up.

In the short term (which this testnet demonstrates), there is not yet any Stacks mining. Instead, each user is a miner—they mine 1-transaction blocks with Bitcoin in order to anchor their Stacks transaction to it.


So, I run a Blockstack node now, in the long term (when stacks goes mainnet), will folks running a Blockstack node also be running a Bitcoin node or will it be just a Stacks node?

Exciting news! Looking forward to playing around with it soon.

1 Like

Such a huge step! Awesome Job guys!
Historic Announcement IMO !


I begin to try it,and got stuck at first step after I typed " npm install blockstack",


What should I do ?
@jude @aaron @jackzampolin @yukan

Huge Milestone and started using it :slight_smile:


Not able to run it on mac:
I clones cli-blockstack repo and installed feature/stack-transactions branch of blockstack.js
when i try to run sudo npm link, it fails saying couldn’t find module blockstack
3: const blockstack = require(‘blockstack’);
^^^^^^^^^^^^ blockstack. Required module not found

3: const blockstack = require(‘blockstack’)
^^^^^^^^^^^^ blockstack. Required module not found

3: const blockstack = require(‘blockstack’);
^^^^^^^^^^^^ blockstack. Required module not found

Found 3 errors

Help will be really appreciated.


You need to install blockstack.js from source: Once you have cloned the repository, you need to check out and install the feature/stacks-transactions branch, run npm install, and then sudo npm link.

Once you have done this, you must install the CLI from source: Then, you need to run npm link blockstack to link the feature/stacks-transactions branch you installed into the node_modules directory for cli-blockstack. After that, you can run sudo npm link to install the CLI to /usr/bin/cli-blockstack.

1 Like


This error is due to a known bug in flow that prevents it from following symlinks in node_modules (i.e. the result of npm link blockstack). They can be ignored.

I installed blockstack.js and feature/stacks-transactions branch ,then I tried install CLI from source: .

git clone
cd cli-blockstack
npm link blockstack
sudo npm link
Error began shows

1 Like

Here’s what worked for me running node with config locally, instead of using global/sudo on Debian:

git clone
cd blockstack.js
git checkout -b feature/stack-transactions
npm install
npm run build
npm link 
cd ..
git clone
cd cli-blockstack
npm link blockstack
npm install

I was having a hard time using Gitcheckout. For some reason it was installing version 17.2.0 when I checked the package.json file. Instead of using Gitcheckout I just downloaded the Feature/Stacks-Transactions branch directly onto my computer, renamed it Blockstack.js and dropped it in the file. I then ran npm install and sudo npm link. After that everything worked when installing the CLI. Let me know if that works for you.

Here’s a tutorial I made about installing the CLI so you can interact with the Stacks Testnet:

Blockstack-CLI Stacks Testnet

Hopefully it’s helpful to you!


Awesome video @Kitsana! With your permission, can I link to it from the testnet page?


Many tnx @Kitsana for the tutorial. I managed to install and test everything and registered a name on the id2 namespace. Lovely!


Many tnx @jude for the blockstack.js-based blockstack-cli. It works nicely.

Few questions for you:

  • Would be nice to have the info command to follow the registration process.
  • I did not get a price for a subdomain. Not implemented yet?
  • It seems I’m earning bitcoin by just registering, doing a profile signing etc. :smile: . Is this by design or bug?

You can probably track my steps via the yeffi.id2 I registered.

1 Like

@jude I’d be honored for the video to be there. Thank you so much for asking. Cheers!