Restoring Keychain in Version 0.26.2

I originally setup my Blockstack wallet and ID in early November 2017. Upon updating to the latest version .026.2, Blockstack required me to restore my keychain.

However, despite all attempts at entering the keychain phrase, the pop-up keeps saying it is invalid. I am 100% certain I am entering the original keychain phrase and have had no prior problems.

Is anyone else having this issue with the latest upgrade and/or is this a known issue? I am on MacOS using Safari.

@PauRocky Have you tried doing a hard refresh or reinstalling the Blockstack app, then restoring your keychain?

@sebastian welp, there we go. Did both and retried. All set now. Grateful for a simple solution and thankful for the input to troubleshoot!

1 Like

Excellent, glad I was able to help @PauRocky!

1 Like

Hi @PauRocky. In what order did you do the restore? Firs new install and then the hard refresh?
Also, how did you do the hard refresh on Safari (Mac).

It tried numerous things, but it didn’t work for me.