Received Stacks Invalid in Stacks wallet

Hello,
First my problem: Received Stacks Invalid in Stacks wallet. See attached Screenshot’s
I have spent many hours researching my problem and have found many entries online with users who have had the same problem. Unfortunately, after reading through many threads I have still not been able to find the solution. I have upgraded my very old Stacks wallet to the latest Hiro wallet but after inputting my seed phrase It still shows no tokens. I’m guessing you still need to deposit a small amount of BTC but when I try using Ledger live android app it returns a “not a BTC address” and will not let me send BTC to the wallet. Not sure if there is a way to add BTC as a custom coin?? I’m not even sure if that is the problem. I have had these tokens for a few years bought them and then kinda forgot about the protocol. I’m pretty sure I upgraded the wallet to the Stacks wallet somewhere along the line. I really do not remember if I bought these during the initial offering but I’m sure that I had the tokens in my custody and fully in control. Okay after further review of the block explorer it looks like the tokens were minted in 100 token lots. The block explorer shows the same number of tokens as Stacks wallet received “invalid” except the block explorer does not show the invalid. Okay so the email system will not let me upload screenshots. Not sure what to do now? I could open a new issue on github at hirosystems/stacks-wallet Please HELP!!

There’s no attached screenshot, and yes opening an issue on Github is the best place to start.

It sounds like you’re getting mixed up with pre-mainnet concepts, where BTC was used to pay fees. This is no longer the case.

If you had funds in a wallet pre-mainnet launch, you can access them by restoring the wallet with the same seed phrase. If you had funds, they’ll be there. You’ll need the Stacks Ledger app not the Bitcoin one.