Problem with Radiks and new blockstack accounts

While using the new beta version of Radiks (the one that validates the username
I was doing some testing and I noticed a problem with the fact that usernames are being validated with the Blockstack API. While doing some tests I created a new account on Blockstack, then when I tried to log in I got an error which resulted at the end in some super strange behaviour.

Basically, when the server tried to verify the user with, the server responded with a 404 error { '': { error: 'Failed to get name record: Failed to load subdomain' } }
The call to the API is now working but it returned this 404 error for at least half an hour.

Does this mean that new accounts can’t be logged in directly with this new version of Radiks?

Hey, sorry to just get back to you on this. I’ve been traveling recently, and am now back.

I think this is just another issue we’ll have to fix before releasing this new version, which is still in beta. I think we’ll have to change the user lookup method to use their DID (or similar), instead of their username.

@hank so if we query the DID instead of the username, even if the block is not mined yet the API will be able to resolve the good identity for a new account?