Newbie devs need help

Having issues setting up Blockstack Browser. I’ve been following the read-me here for the past couple of days:

Installing blockstack core was fine but then I’ve been stuck installing blockstack-portal, particularly when running npm install (I’ve updated node js and npm). The error returned references updating babel-runtime to 6.23.0 and minimatch to 3.0.2. I tried running npm install [email protected] --save-dev and npm install [email protected] --save-dev and while this had the package.json file updated with the requested version numbers as intended, running npm install again still returned the same error regarding the need to upgrade babel-runtime and minimatch. I’m not so familiar with these dependencies however can someone please help confirm what need to be done to get the installation completed? Or does the read-me need to be updated with the currently working steps to follow? I’m trying to install on Ubuntu.

A regularly updated landing page new devs with clear steps to follow, where to start, etc would also help a whole lot.


Hi arigbs

Same here! Had a few issues when installing… the worst hack I had to pull off was manually copying a shared library for the internationalization stuff… it worked the first time, but after a reset, i can’t start the proxy now (core seems to be responding though)

The only help I can lend you regarding node, is that it required A LOT of free space to install everything, much of it is returned later but, had to retry a least a couple times after freeing some. I’d suggest minimum of 1Gb or 1.5 Gb!

Also, from the blockstack core instructions, it seem to use node 7, and there was one package which suggested it wanted >=6 but when I used 6, another package complained about GLIBCXX (or gcc?) as it wanted 3.4.20 and mine was only going to 3.4.19.

Now I’m using node 4 and it works… at least the 1st time around it did, babel core is complaining now… researching the following suggestions:

Updating: Tried manually (re)installing babel-register, and a cache clean (as per my link above) and at least now the error is more useful: ReferenceError: Unknown plugin “transform-object-rest-spread” specified in “/root/spot/blockstack-portal/.babelrc”

(after digging it out from all the surrounding stuff).
The suggested addition to .babelrc (from the link) is already there. So, anyone has a clue on this plugin and why it’s disappeared? Thanks.

Update: Reinstalling the plugin seem to have worked but then it halted at the next problem, so I’ll redo the npm install to maybe fix every one, since it worked the first time…

Gave up trying to figure this out on my own. Hoping one of the devs might weigh in to confirm if and what may be broken or what might not have been done right.

Fixed on my side… as it turns out, installing node 7 was enough. There was a few warnings for deprecated stuff but, nothing prevented it working at the end.

I hope this helps.