New Blockstack-CLI Transfer questions

Hi @jude. I’m trying to do a transfer with your new Blockstack-CLI.
These are the commands:
–new_id_address ID-ADDRESS
–keep_zonefile TRUE-OR-FALSE
–owner_key PRIVATE_KEY
–payment_key PRIVATE_KEY

The first, is that the Blockstack ID (with the .id at the end)?
The owner_key, from the sender or the target wallet?
Idem for the payment_key.

I tried all combinations, but it didn’t work.

Hey @jefvanbockryck,

The owner and payment private keys are from your wallet. They correspond to the “current” name owner. If your name is owned by a 12-word bip39 mnemonic from the Browser, you can use the new CLI’s make_keychain command to get the owner and payment keys.

If your name is owned by the “old” blockstack CLI (the one called blockstack, not blockstack-cli), and if your names are owned by a single private key (i.e. the address starts with 1, not 3), you can do the following to use the new CLI to do the transfer:

  1. Dump your owner and payment keys from the old CLI using blockstack wallet. You will be prompted for your wallet password. Note that this wallet corresponds to your ~/.blockstack/wallet.json file, not your Browser wallet.
  2. Use the owner and payment keys in the new CLI to transfer your name as follows: blockstack-cli transfer YOUR_BLOCKCHAIN_ID THE_NEW_ID_ADDRESS true YOUR_OWNER_KEY YOUR_PAYMENT_KEY. Example:
blockstack-cli transfer ID-12iMuRTNUFguprBZzA6GzqLTwipv5KBnmw ae4e9a43fdd41042a2d786e04941ac67eab7f09789a16a6124e3ddae8e12d76a01 7b051ca3a5b5d292d3602c1f2c0c311317687e11c3d379838970ff6ee6d7b02201

However, if your name is owned by a multisig address (i.e. one that starts with 3), you will need to use the old CLI to do the transfer. The syntax is simply blockstack transfer YOUR_NAME YOUR_NEW_ADDRESS. You will be prompted for your old CLI’s wallet password.

Hope this helps!

Hey @jude, tnx for the answers.

It doesn’t work with the new blockstack CLI, so I used the old one and that works still pretty good.


When I tried using the blockstack transfer, I keep getting the error: No JSON response" “http_status: 500”

Any thoughts?