Names registered, some showing up in my IDs, some not

Last week I bought a bunch of IDs on Blockstack. Very excited about what you guys are building.

7, however, are not showing up in my list of IDs. Some were before but I was recommended by Sebastian in support to reset, which I did. I had to go in an create a bunch of IDs (only my primary showed up at first which scared the crap out of me), and sometimes those new IDs were replaced by the IDs I’d bought.

Now I’m missing 7. In my IDs, I see but not, yet on the Explorer, it shows they have the same owner. So that should be me…

Same story with and I see p.idin my IDs but not j

I’m also missing 5 more:,,, and Weird thing is, these 5 all showed up before the reset and were there for days but with a little clock icon that never went away.

If those IDs were registered at the same time, if I was competing with someone (which I can’t be sure if I was or not), shouldn’t I at least get my BTC back for those I didn’t get?

I spent a lot of money on these and am deeply worried that I’ve either lost the ID or the bitcoin or both

This is the Blockstack wallet address. I both pay for them by sending BTC to my Blockstack QR code and by snapshotting the QR code after search and sending from my Coinbase account (they may have gone to the same place, it was a little difficult to tell).


As far as I can tell from my side of things, I should have all of these IDs and yet for some reason I don’t.

I’d love any help.


1 Like

I am not an expert, so take this with a grain of salt.

My understanding is that the Blockstack Browser will only display the first ID registered to a particular address. You registered and to the same address so only will show up in the browser. However, you own both. Future improvements to the UI of the Blockstack Browser will be necessary to make managing multiple IDs on the same address better.

Same thing with and .

However, your registration of , , , , and never competed and you do not own these IDs.

Registering an ID requires 2 transactions on the blockchain. The second transaction does not start until the first one is confirmed (which is why the Blockstack Browser has a warning about keeping it open for an hour). It’s likely that your browser sent the first transaction (called “NAME_PREORDER”) which burns the bitcoin for the ID but did not send the second transaction (called “NAME_REGISTER”) which gives you the ID.

Your bitcoin is gone and you lost these IDs because the re-entered the pool of available names.

It looks like you have a lot of other short ones though!

how exactly do i go about securing a domain for myself??

Install Blockstack Browser. Click “IDs” at the top. Then “Add a username.”

the issue is that when i do that it’s telling me “You cannot purchase usernames in this build. Feature coming soon!” …


You need to download the actual Blockstack Browser and not use the web client.

I thought that’s what I downloaded… where do I download that from?

A similar thing is happening to me. It’s only showing the first id I own under the “Ids > More” but not the other two. I’ve tried restarting Blockstack. I also tried clearing the local storage. Just looking for a solution to get them back. There are no clear errors being thrown in the console.

Im currently logged into all three on another computer (See photos).

I have the same problem. When I log in with the newest Blockstack browser I have one ID, With an older version I also have,, and

As far as I know, there is still no tool to convert from the old version to the new version so we can regain access to our IDs.

Does anyone know when such a tool will be available?

There is currently a bug where the browser doesn’t properly order the IDs when they are generated. It can lead to usernames “disappearing” we are working on fixing it in this sprint. Here is the issue for tracking progress:

You can always clear localStorage and restore from backup to solve this issue as well.