Names available in Explorer are taken at registration

I want to be This name is not found in Explorer. But it is taken when I try to register it. And then going back to Explorer it’s still not there. What gives?

This is likely due to your browser not having access to the data. Try quitting blockstack and restarting. That should help.

So I restarted Blockstack. Took a little while to figure out that this is done in the menu bar, not by quitting Safari. The issue persists. “” is not found in Explorer. “” is taken when I try to register it. -.-

Hi @finkga, the name you’d like to register is still available:

Can you try to do a hard refresh of your browser to see if this resolves the issue?

And if you have updated your OS try to restart your computer.

Unfortunately, none of these approaches has helped. Safari does not have a hard refresh feature. You can choose to erase all your history, bookmarks, and cookies, but this is not tenable.

So I tried FireFox. That was even worse. My bio and social connections were gone, and I couldn’t even enter the name I wanted to search for.

So I tried Chrome. That was the same as FireFox except I could enter the name, any name, and it says it’s taken.

I have noticed that very long names like a whole bunch of hexadecimal text are possible to reserve. But who wants them?

So I’m pretty much at the conclusion that BlockStack isn’t ready for primetime yet. Too bad. I have a blockchain application I would love to field on it. Hopefully, I can eventually get it to work because it would save me lots of effort.

A further observation: It appears that any name longer than 34 characters is available. But I’ve found no name with fewer than 35 characters that is available. So
1234567890123456789012345678901234 is not available but
12345678901234567890123456789012345 is.

Seems like the problem I’m experiencing is caused by something different than the proposed solutions address.

Further update: Restarting had no effect. All names under 35 characters report being taken.

Ok, sorry about that, you can try to restart everything:

1/ Go to Blockstack Settings.
2/ Settings: Backup keychain (keep it as your life).
3/ Settings: Reset Browser.
4/ Clear Chrome browsing data.
5/ Restart computer.
6/ Launch Bolckstack and restore your account via your keychain.
7/ Try add and buy your username.

“Success consists of going from failure to failure without loss of enthusiasm” Winston Churchill

Nice Churchill quote. How about the definition of insanity as doing the same thing over and over and expecting different results?

I’ve already done this (see above). With Safari. With Firefox. With Chrome. And I’ve restarted my computer. BTW, backing up the keychain and restoring does not save your name and bio. I’ve had to redo those each time. And to change browsers, I had to change the MacOSX default browser and then open the Blockstack home window.

The answer you gave above tells me you basically have no idea what’s going wrong. OK. Can we debug it more closely? Are there debug settings I can enable? Tests I can run? Version information or configuration files I can offer you? I’d like to solve the problem, but your answer is like when the help desk says unplug it, wait two minutes and try again. If it doesn’t work, repeat. Doesn’t seem helpful or thoughtful.

Ok… walk your path…

It’s not like I haven’t tried to follow your advice. It is that following it (repeatedly and under a variety of circumstances) has not worked for me. Are you not curious as to why I can create any ID greater than 35 characters and none with 35 or less? Would you please help me fix this problem or at least help me examine it more closely? I am a computer scientist, so I might be able to help you debug your system if you let me. Your last response made me think you are just dismissing me, and I find this disappointing.