Name registration using ADD A USERNAME

Hi All, I tried to register yesterday and I can see that the fee required at that time is taken from my blockstack browser wallet:
I was using v0.19.1. But the status was ‘Name registration in progress’ even after 8 hours.
Then I upgraded to version 0.20.0, cleared the browser cache and restored using the backup phrase,

  1. All my social account verification are gone
  2. The “Name registration in progress” status and the blockstack ID are gone
    But it properly displays my wallet balance.

I tried again to register the same blockstack ID that I paid for earlier using the Add Username link, and it displays that the ID is already taken

But the explorer says it doesn’t exist:

I also have same problem.

@muneebm Can you share your identity address please?

Sorry it’s taken a bit for us to help you with this issue.

Thanks for the reply @jackzampolin
This is my identity address: 1fnBqkHSA1aJ2D9DBE7qmroUMbNr7PjW1
and this is my browser wallet address: 1PDyb8ajxm7SoJrkhVQQeDLHWv3AJuKpHX

1 Like

Hey @muneebm, sorry to hear you’re having trouble!

Name registrations usually take about 1-2 hours, since the software has to send and confirm two bitcoin transactions in the background. If the Bitcoin blockchain is under heavy load (like it was last night), it can take longer.

It’s possible that by upgrading while the name was being processed, the procedure got interrupted and didn’t run to completion. If this is the case, then the only solution is to try ordering it again :frowning:


Hi dear friends,

I registered the username “” in the past and I have its password, but I cannot now add it to my Blockstack browser since it says that this account is already taken.

I also cannot remove two of my Blockstack IDs which do not work: “” (because of its name registration being in progress for over two months) and “Add username”

Can anyone help with such issues?