Multiple identities (different owning addresses) lost

I’ve just upgraded to blockstack browser 0.31.0 - Mac OS Sierra.

I have 3 identities:

  1. 13cuYFmbEnnL9CnRUNWRxVxSoVyc3QFKKd

  2. 14FXKtccHBNfKpc7JoAyDf4mrGKR5CbyDT

  3. 1CGfVfKFrhxmYtRFmrhgsjZg9i7hc7DaBk

under the same seed. I’m testing with multiple identities and browsers and thought it was just firefox not showing 2 and 3. I then restored in chrome from seed and found 2 and 3 disappeared in chrome.

This seems different from the reported bug where multiple identities are not shown when owned by the same identity address as in this case the owning addresses are different.

Any help greatly appreciated!

PS I tried rolling back to previous browser version but found the same in chrome - seems to have been the ‘restore browser’ operation that caused the change.

Continued messing around and found the following…

Click ‘more’ at
Then ‘Create New Id’ (entering wallet password) then ‘Add Username’

recovers the missing identities one at a time.

Hi Mike,

That’s correct, to reveal previously purchased IDs after restoring your keychain, you’ll have to manually add them via IDs > More > Create New ID for each Blockstack ID and username you purchased. The wallet generates the addresses deterministically, so they are always the same. We currently have an open issue to improve user experience and avoid confusion:


I have the same problem following a recent update. I have two usernames (shown here: The one is showing but not my previous default one ( I tried the technique above to add new ida. I can add them, but when I try to add a username to the newly added id it says it’s already been taken (which is right, except that it should recognise that it is mine?). There is an option to transfer an ID from OneName but I didn’t purchase mine from OneName as far as I can remember. Does anyone have any advice?

Hey @stefanf28, it looks both of your names are owned by the same address. The Blockstack browser only displays 1 name per address currently.

Thanks @yukan - yep, it’s been like that for a while but before the recent update it was showing my default (fully validated) username Now it’s randomly chosen which I’ve just reserved for future use. You don’t know if there’s a way to force use of the other one instead?

(PS I’ve always been quite confused by the fact they have the same address because I originally purchased the second one using the add id function (which I thought gave a separate address))

Update. Just saw that someone’s already answered this question in another thread I commented on (just forgot): Switching between multiple IDs that have the same address?

Will be really good for this issue to be fixed from a UX point of view!

Agreed, although it might be better UX to keep a 1 to 1 correspondence between names and addresses. In that case it would be best to transfer one of the names to another address.

Also, I think you ended up with 2 names to 1 address due to an old browser bug where multiple generated ID’s had the same address. This issue has been fixed for a while and no one should be running into the problem going forward.

Yeah that’s partly what I mean by UX improvement. Would love to transfer the name to another ID but I can’t figure out how to do this. When adding a new ID in the browser there’s the option to transfer a name from OneName but I purchased my names via the browser in the first place, not OneName.

And when I just try to add my existing name to a new ID in the browser it says it’s already been taken - i.e. it doesn’t recognise that the ID the name belongs to is already listed in the browser I’m authenticated in, so it doesn’t recognise me as owner of the original name.

So there doesn’t seem to be an easy way to do this unless I’m missing something?