Linux Mint 18.2/Ubuntu 16.04 Installation tutorial

Hello,

I’m having a hell of a time trying to install blockstack on Linux Mint 18.2

I installed Docker using this tutorial because even they don’t provide a tutorial:
http://linuxbsdos.com/2016/12/13/how-to-install-docker-and-run-docker-containers-on-linux-mint-1818-1/

Then rebooted and went to launch Blockstack which I had installed before Docker because I wasn’t informed that Docker needed to be installed first. Then this:

[email protected] ~ $ cd Downloads
[email protected] ~/Downloads $ ./Blockstack-for-Linux-v0.20.1.sh

blockstack docker launcher commands:
pull -> fetch docker containers from quay
start -> start the blockstack browser server
stop -> stop the blockstack browser server
logs -> access the logs from the blockstack browser server
enter -> exec into the running docker container

To get started, use

$ ./Blockstack-for-Linux.sh pull [THIS FILENAME IS INCORRECT]
$ ./Blockstack-for-Linux.sh start

This requires Docker to run.

And this will start the environment for running the Blockstack Browser

Note: the Docker containers mount your /home//.blockstack directory

[email protected] ~/Downloads $ ./Blockstack-for-Linux.sh pull
bash: ./Blockstack-for-Linux.sh: No such file or directory
[email protected] ~/Downloads $ ./Blockstack-for-Linux-v0.20.1.sh pull
Got permission denied while trying to connect to the Docker daemon socket at unix:///var/run/docker.sock: Post http://%2Fvar%2Frun%2Fdocker.sock/v1.29/images/create?fromImage=quay.io%2Fblockstack%2Fblockstack-core&tag=v0.20.1-browser: dial unix /var/run/docker.sock: connect: permission denied
Got permission denied while trying to connect to the Docker daemon socket at unix:///var/run/docker.sock: Post http://%2Fvar%2Frun%2Fdocker.sock/v1.29/images/create?fromImage=quay.io%2Fblockstack%2Fblockstack-browser&tag=v0.20.1: dial unix /var/run/docker.sock: connect: permission denied

OK, I’ve been tracking down the errors and starting to figure this out.
I needed to launch Blockstack with sudo ./Blockstack-for-Linux-v0.20.1.sh

Still…a full step-by-step installation tutorial for Linux users is needed, by someone much more advanced than I am.

Hey @steviedeeee, sorry to hear you’re having trouble!

It looks like you’re doing all the right things–install docker, run the script with the pull directive, and then run the script followed by the start directive.

In most linux distros, installing Docker creates a docker group. Your user must be in this group. You can add yourself with sudo usermod -a -G docker <your username>, and then logging out and logging back in.

Example from my laptop:

$ groups                                                                                                                                                                                                                     
jude audio video kvm qemu staff
$ sudo usermod -a -G docker jude
Password:
$ logout

And when I log back in, I should see that my group membership has changed:

$ groups
jude audio video kvm qemu docker staff
1 Like

Thanks @jude, I really appreciate the assistance.

Adding my user to the group worked as recommended, and then I started up blockstack from the command line:
$ cd Downloads
$ sudo ./Blockstack-for-Linux-v0.20.1.sh start

When I start Blockstack-Browser from the program menu in Linux Mint, I’m taken to a screen which says:
“Please pair your browser with Blockstack”

However, unfortunately there is no Blockstack icon in my menu bar. How do I make it appear?

Thank you!

I also have this issue.

Hey @steviedeeee, @JSewell-Git,

There won’t be a Blockstack icon in the menu bar in Linux. The fact that you got it to work earlier with sudo may have caused some partially-written state to stick around in the web browser.

Can you try opening a developer console window and clearing localStorage, and then doing a hard-refresh? In Chrome, the developer console can be accessed with Ctrl+Shift+i. You need to navigate to the “application” tab, make sure “Local and session storage” is checked, and click “Clear site data.”

Having the same issue on ubuntu 17.10, tried “Clear site data” then “empty cache and hard reload” no joy.

Getting this Warning in the /home/tkb/.blockstack/api_endpoint.log…

/home/tkb/.blockstack/api_endpoint.log.1510350306:[2017-11-10 21:40:02,450] [WARNING] [dropbox:188] (47) Config file '/root/.blockstack/client.ini': section 'dropbox' is missing 'token'.  Write access will be disabled

Not sure that this warning has anything to do with the {pair your browser" issue, but there you have it anyway.

Thanks, Tom

Hey @tkb608,

When you run the Linux script, is the browser opening on its own, or are you navigating there manually? The script is supposed to launch the browser automatically, with a special query string to make sure that screen gets skipped.

Can you confirm that the file ~/.local/share/applications/blockstack.desktop exists, and that xdg-open is installed and is able to open your browser?

Navigating manually. But yes xdg-open is installed and ~/.local/share/applications/blockstack.desktop exists.