How to solve https hosting for "Failed to fetch information about the app requesting authentication"

I think the issue is the godaddy https hosting. What is the exact configuration I need to work with godaddy?

The following is the brief I worked on:

I registered domain name from godaddy and host blockstack app on https. Somehow, I still got error for DNotes App. So, I build and deployed the simple animal kingdom demo project.

I did the following steps:
1. reinstall unbuntu
2. install nodejs and npm
3. download animal-kingdom zip
4. unzip
5. npm install, npm run build
6. deploy animal kingdom build to godaddy https hosting site

I go to, The landing page is shown up. It ask me to recover blockstack ID and restore ID works good.

Then, after I click “Sign in with Blockstack”, it gave the error page.

I copied:

error message “Failed to fetch information about the app requesting authentication. Please contact the app maintainer to resolve the issue.”

The blockstack ID I registered is “”

If I run the same project locally by “npm run start”, page is shown correctly in local.

thank you very much for your help and time.


Hey is it serving manifest.json correctly from the root of the deployment on godaddy?

Easy to check by going to https://domain/manifest.json


Attached screenshot is the manifest.json on the

Does it missing anything?

(the https site is hosted in godaddy, the build is straight from animal kingdom project, I didn’t make any change)

thanks a lot for your help,



The screen shot in my previous post might misleading. The “Access-Control-Allow-Orgin” section shows because I am testing by manually adding it to manifest.json file.

I rebuild the project by “npm run build” and deploy to godaddy. The raw content of manifest.json is as followings:

“short_name”: “Animal Kingdom”,
“name”: “Animal Kingdom”,
“icons”: [
“src”: “”,
“sizes”: “192x192”,
“type”: “image/png”
“start_url”: “./index.html”,
“display”: “standalone”,
“theme_color”: “#000000”,
“background_color”: “#ffffff




By researching on the forum, I found a solution. (I still can’t solve the issue at godaddy, however, it works good at netlify)

The reference forum post is:

I manually added “netlify.toml” into the build folder with the following data content inside the file:

 # The following redirect is intended for use with most SPAs that handle
 # routing internally.
 from = "/*"
 to = "/index.html"
 status = 200

 # Define which paths this specific [[headers]] block will cover.
 for = "/*"
 Access-Control-Allow-Origin = "*"

Thank you very much for all the help.