How to recover BTC from old Blockstack (0.34.1) wallet from 2018

I have some BTC in my Blockstack wallet which no longer is able to send, I suspect it’s related to the old api endpoints being out of use? Is there any way to recover my payment keys? I also don’t seem find a ~/.blockstack/wallet.json, or even a ~/.blockstack/ folder

Screen Shot 2021-02-06 at 1.17.44 PM

Screen Shot 2021-02-06 at 1.18.44 PM

Yeah you have the private key for that BTC (the same seed that worked for the STX), so it’s possible to sweep that BTC. I think there is already a Github issue tracking this. I’ll let someone from Hiro engineering team chime in RE the status of that issue – thanks!

1 Like

sweet would love to track that issue if anyone can link that!

Any updates on the status of this issue @muneeb (or someone from Hiro)?

Thanks for flagging Daniel, cc’ing @markmhendrickson on this thread!

Thanks for reaching out to us about this, @dwang. Sending from this BTC wallet should still work, so I’ll dig into why this is broken for you soon next week.

@dwang I just tried to send BTC using the wallet in the Blockstack Browser and it worked for me. However, I noticed that it doesn’t show an error in the UI when an incorrect password is entered (though it does throw an error in the browser’s console).

Mind indicating just what behavior you see with the wallet when trying to send?

I’m on a very old version which was last installed in 2018 (0.34.1), and I think a lot of the old apis are outdated and are erroring out, but I’m not sure where I can go to update or install the latest Blockstack Browser that you said works for you?

I’m using the hosted version of the Blockstack Browser here, which has the latest version: https://browser.blockstack.org/

You may want to try the latest release for download here if you prefer not to use the hosted one like I did: Releases · blockstack/blockstack-browser · GitHub