How to check current blockstack-core version?

I am looking to upgrade my server to blockstack-core version 0.17 but am a bit confused on where to see which version I am currently running. I suspect it is 0.14 but I am not sure. Where can I check this through the command line?

Hey @blockpac,

You can use blockstack-core version to get the version number.

1 Like

Hi @jude
Thanks for that. I am running on my local machine and just did the following:

  1. blockstack-core stop
  2. renamed ~/.blockstack-server to something with ‘old’
  3. blockstack-core fast_sync
  4. blockstack-core --debug start

However when I run blockstack-core version after these steps, I still have version ?

What am I doing wrong? These are my logs -->

sudo blockstack-core fast_sync
Synchronizing from snapshot. This will take about 10-15 minutes.

bzip2: (stdin): trailing garbage after EOF ignored
Node synchronized! Node state written to /root/.blockstack-server
Start your node with blockstack-core start
Pass --debug for extra output.

sudo blockstack-core --debug start
[2017-11-11 15:57:37,739] [DEBUG] [spv:103] (10781.140099902859008) Using mainnet
[2017-11-11 15:57:37,958] [DEBUG] [config:1081] (10781.140099902859008) Load config from ‘/root/.blockstack-server/blockstack-server.ini’
[2017-11-11 15:57:37,960] [DEBUG] [blockstackd:2451] (10781.140099902859008) config:
“bitcoind”: {
“bitcoind_p2p_port”: 8333,
“bitcoind_passwd”: “blockstacksystem”,
“bitcoind_port”: 8332,
“bitcoind_regtest”: false,
“bitcoind_server”: “”,
“bitcoind_spv_path”: “/root/.virtualchain-spv-headers.dat”,
“bitcoind_timeout”: 300.0,
“bitcoind_user”: “blockstack”
“blockstack”: {
“announcers”: “,,”,
“atlas”: true,
“atlas_blacklist”: “”,
“atlas_hostname”: “debian”,
“atlas_seeds”: “”,
“atlasdb_path”: “/root/.blockstack-server/atlas.db”,
“backup_frequency”: 144,
“backup_max_age”: 1008,
“data_storage_drivers”: “disk”,
“email”: “”,
“profile_storage_drivers”: “disk”,
“redirect_data”: false,
“rpc_port”: 6264,
“serve_data”: false,
“serve_profiles”: false,
“serve_zonefiles”: true,
“server_version”: “”,
“zonefile_storage_drivers”: “disk,dht”,
“zonefiles”: “/root/.blockstack-server/zonefiles”
[2017-11-11 15:57:37,966] [WARNING] [blockstackd:2797] (10781.140099902859008) Server did not shut down properly. Restoring state from last known-good backup.
[2017-11-11 15:57:37,967] [WARNING] [blockstackd:2812] (10781.140099902859008) State from crash stored to ‘/root/.blockstack-server/crash.1510369057.97’
[2017-11-11 15:57:37,967] [DEBUG] [indexer:483] (10781.140099902859008) Restoring ‘/root/.blockstack-server/backups/blockstack-server.db.bak.493919’ to ‘/root/.blockstack-server/blockstack-server.db’
[2017-11-11 15:57:38,187] [DEBUG] [indexer:483] (10781.140099902859008) Restoring ‘/root/.blockstack-server/backups/blockstack-server.snapshots.bak.493919’ to ‘/root/.blockstack-server/blockstack-server.snapshots’
[2017-11-11 15:57:38,193] [DEBUG] [indexer:483] (10781.140099902859008) Restoring ‘/root/.blockstack-server/backups/blockstack-server.lastblock.bak.493919’ to ‘/root/.blockstack-server/blockstack-server.lastblock’
[2017-11-11 15:57:38,193] [DEBUG] [fast_sync:590] (10781.140099902859008) Restored backup from 493919
[2017-11-11 15:57:38,193] [WARNING] [blockstackd:2817] (10781.140099902859008) State reverted
[2017-11-11 15:57:38,193] [INFO] [blockstackd:2832] (10781.140099902859008) Starting blockstackd server (working_dir = ‘/root/.blockstack-server’) …

@jude update:

When I run ‘blockstack info’ I get:

blockstack info
“advanced_mode”: true,
“cli_version”: “”,
“consensus_hash”: “0e480fe76a3780ae8af0f60434cfa4a5”,
“last_block_processed”: 493961,
“last_block_seen”: 493969,
“server_alive”: true,
“server_host”: “”,
“server_port”: 6264,
“server_version”: “”

Seems like the server is at version but the CLI is at ?