Has Anyone Successfuly Deployed a Gaia Hub Using Blockstack's Tutorial?

I’ve seen at least one other (still unresolved) forum post about deploying a custom Gaia hub using Blockstack’s official documentation. I just tried to follow the documentation and also could not get it working.

So I wonder, has anyone that doesn’t work at Blockstack actually been able to follow the documentation here successfully?

2 Likes

Are you encountering the same problem as that other forum post or something different?

Same. Follow the tutorial verbatim, get a freenom domain, enter the config settings as documented, and it all results in a 502 bad gateway. My guess is something is missing from the documentation.

I’ve gone back to just building up my own Gaia server and then deploying myself but it worries me that the “simple” solution documented doesn’t appear to work.

I remember testing this months ago when we first published it and it worked then. But I’ll run through this again today to see if I can still get it to work myself.

We certainly want to fix anything broken (especially if it’s happening to multiple users here).

1 Like

We seem to have an issue in the image causing problems:

@markmhendrickson and I are going to test the actual instructions to the existing tutorial instructions.

1 Like

Where is the github issue in question? That link it to the docs.

Here it is:

Hello, I am new to stacks. I ran into an issue with deploying gaia-hub on AWS EC2, so thought of commenting in an existing similar issue instead of starting a new thread.

I started following guide to setup gaia-hub on AWS EC2: Deploy on Amazon EC2 | Stacks using t2.medium (flavor) and blockstack-gaia_hub-ephemeral-2.5.3-hvm (AMI). I followed the guide verbatim, however I encountered an error, due to which the instance is not reachable and the console is not opening. When I checked the system logs, I got the following:

[0;1;31me[0merror at line 1, column 1
invalid character ‘<’ looking for beginning of value
e[0;1;31me[0mfailed to fetch config: config is not valid
e[0;1;31me[0mfailed to acquire config: config is not valid
e[0;1;31me[0mIgnition failed: config is not valid

I’m guessing it has something to do with the instructions given in step 7, where we have to copy and paste the provided json onto the “Advanced details” section. I have attached a snapshot of json file for reference. The values I’m using are:
hubba
<NAME_O_DOMAIN> lumstx.tk
<STAGING_VALUE> 0

Can anyone guide me what I might be doing wrong ?env

I got past the above issue. It appears that removing the HTML tags from the user data solved the problem.