Guide: Register for Token Sale without installing Blockstack Browser

It’s best to use the Blockstack Browser locally installed to do this. But if you get trouble, there is another way.

If you have trouble doing this recipie, you could try doing it in a Private Window. However, then be extra doubly sure you copy your keychain backup phrase so you can control your account later.

Set up your keychain

  • Go to
  • Choose Try Preview
  • Create a new account (or you could restore your existing key chain, but be aware that is hosted by blockstack so it’s not local)
  • Write down the keychain (you’ll need it for later)

Optional: test that login works

  • On, go to IDs page
  • Set your name, don’t care about anything else for now
  • Go to Home
  • Open ‘Hello Blockstack’ (sites requiring Gaia storage currently won’t work with web-based blockstack)
  • Open Devtools (CTRL+Shift+I), go to the networks tab
  • Click ‘Sign in with Blockstack’
  • If a new tab opened, that would be your local blockstack installation, ignore this one
  • There will be a blockstack URL at the bottom of devtools, right click and ‘Copy Link’
  • Now write a new URL into your address bar (remember to paste the link where it says):
  • It will ask you if you want to sign in, press yes
  • You should now see "Hello, " on

Verify your accounts

  • Go to
  • Click ‘IDs’
  • Fill in your name and bio
  • Two recommended verifications to try is GitHub and Twitter
  • For GitHub, write in your GitHub username, and add your gist, it should look like my gist. I did whitespace changes first, don’t do that. You can also check out some full guides for verifications here.
  • Once you have your URL (obviously you need to use your pubkey and your URL), put it into the Blockstack page
  • Click Verify
  • It’ll initially show ‘Unverified’, but after a few seconds you should get a blue checkmark (see troubleshooting if not)
  • You may add more verifications, but with one blue checkmark, you should be able to proceed to register

Register for Token Sale

  • Go to
  • Open up DevTools (CTRL+Shift+I), and go to the Network panel
  • Click ‘Sign in with Blockstack’
  • If a new tab opened, that would be your local blockstack installation, ignore this one
  • There will be a blockstack URL at the bottom of DevTools, right click and ‘Copy Link’
  • Now write a new URL into your address bar (remember to paste the link where it says):
  • It will ask you if you want to sign in, press yes
  • You should now be able to register to the Token Sale!


Verifications are not working, showing unverified!

Several things can be wrong here. Twitter and GitHub are the simplest forms and will often work well.

  • First of all, sometimes it seems to just fail randomly. Reset and retry your verification:
    • Open up the verification inside Blockstack again
    • Clear all the fields (username and URL)
    • Click “Verify” and go back
    • The verification should now be gray again
    • Re-do the creation of the verification (you don’t need to re-do the actual verification on the social accounts (if it is correct, see below)!).
    • Write in the user name, and copy in the URL, click Verify.
    • If it works for you now, awesome!

Still failing?

  • Make sure the URL is public, i.e. that you can get it if you use curl in a terminal, or a different browser
  • Make sure you wrote in your account name correctly
  • Make sure the public key you entered in is shown correctly
  • Here’s an example for GitHub
  • If it is still failing, you might try to check what the DevTools is saying
  • You only need one proof to work, so if you have that you could potentially ignore the problematic proof for now

I can’t “Sign in with Blockstack”

  • Make sure the URL you create when you want to sign in looks like this (and that you included the full blockstack:-url after authRequest=):<many_more_letters>
  • Make sure you are actually in the correct browser you set up blockstack in and that you have cleared cache and deleted local data.

  • Make sure you don’t actually go to http://localhost:8888-url, that is your local blockstack browser, not what we’re trying to do.

  • Maybe try Private Window?


Hey @odinho, thanks for taking the time to write this up!

Thanks @jude, I’ve been a fan for a long time as you know :slight_smile:

Also I managed to sneak in wrong DNS in most URLs in the guide, it should be not, as I wrote in several places(!).

1 Like

Thank you @odinho for your guides here. While I may not be as eloquent as you in the technicalities of Blockstack, I’d like to share my situation as it may be of relevance to others.

I installed Blockstack on my Linux machine. By running sudo gulp proxy in one terminal and sudo gulp dev in another, I can then access my Blockstack account at http://localhost:3000/profiles. There I was able to connect two social media accounts and receive some Bitcoin. The “add a username” function does not work.

Following some of your instructions above, I was able to create the URL using DevTools. This prompted me for a keychain and I restored the keychain I had created with my local install using the associated keychain phrase. It’s now unclear to me whether my account lives on my local machine or somewhere with Blockstack. Now when I go to the URL I created under your guidance, the “Blockstack Token Sale” sign in request says: “Choose a Blockstack ID to sign in with.” and prompts me with the ID that I can also see at http://localhost:3000/profiles. I click “Approve” and then a page with “Token Sale Registration” in large bold letters loads, or rather appears to load - three dots cycle below those words and nothing further happens.

I’m sure there are a lot of things I’m doing wrong here and any insights would be most welcome.

As long as you didn’t ever write in and instead used http://localhost:8888 everywhere, it will all be on your local machine. Using you also store things locally in your browser as I understand, but you are relying on some server-side helper code run by blockstack. So your keychain ‘lives’ in your browser anyhow, but it will be indexed to the origin, so that could be why you needed to write your backup in again if you suddenly went to instead of localhost:8888.

You do not need any Bitcoin in your account by the way. You also do not need a name to register. You do, however, need to verify at least one account.

Your problem is not one I encountered. I would check the DevTools console, and check for any errors there. I would also try to do a hard refresh first, as the developers have instructed other people. That is often CTRL+F5.

As another potential tryout: if you now actually did seem to use anyway, and just want to get your registration in. I would try to open a Private Window, and with your keychain phrase, retry in this fully new environment.

1 Like

@odinho the private window trick you mentioned in your last paragraph worked for me. I’ll figure out the rest another day! Thank you.

1 Like

That’s great!

Since it worked there, it will probably (for that other day) work to hard refresh your local browser. And if that doesn’t work just clear all your local storage for Blockstack and input your restore keychain phrase. If I understand correctly, your profile with your attestations.

In other news, I just noticed my was just transferred to my former nameless-registration. Awesome :smiley:

1 Like

Just a heads-up on using this guide.

If you have installed Blockstack, you should uninstall it first before trying the Web version

When installed, Blockstack adds a protocol handler for blockstack: URIs. This will interfere with the Web version when you try to sign into an app or the token sale.

I have tried the above method but no URL is coming up under DevTools/Network when I click “Sign in with Blockstack”. Can someone help?


Show a screenshot maybe? Check that there’s no errors in the console too?

You have to have DevTools open, and THEN click the login, by the way, if not it won’t catch the network request.

Also, what browser? Maybe the devtools for non Opera/Chrome/Firefox browsers works differently?

Yes, this is what I am seeing when I follow these instructions. I am not seeing the link that is referenced in the bottom right as the post says.

Did you click ‘Sign in with Blockstack’? The link will only appear once you do that. It will try to navigate to this new page, but should keep the one you have open, if it doesn’t, you can enable the “don’t clear network requests” functionality to make sure you still have the request in your devtools for copying.

(That being said, if the js lib could actually put a href on the sign in button, that would be super awesome since you could then easily just right click and copy-paste the URL, instead of needing devtools.)

Yes, the screenshot I sent you is after I clicked sign in with Blockstack. It opened a new tab to the blockstack browser and per the instructions I went back to the original tab with the sign in option and am not seeing the URL referenced in the troubleshooting guide you wrote.

Thanks for all your help, hoping to get in before the ICO closes :slight_smile:

You have two errors in your console, – maybe those will tell of the problem? Seems to me that the javascript crashed for some reason, so it was never able to get the request done.

… However, you said it opened a new tab! So it must’ve worked. You then got a URL with a ?authRequest= in, you can copy that value to the URL.

Sure, I did that and pasted my URL and got this message back? I am using a PC so not sure what to do now as this is instructions for mac?

What? You don’t seem to be following the guide? This is a guide for using, not the installed version. It would probably be easier if you uninstalled your local Blockstack Browser if you have problem separating which is which :slight_smile:

The answer to your question is, you’re using the wrong URL. You probably have localhost in your URL, you should have in it.

Wow, I feel like a goober sorry for the issues :slight_smile: I was able to register and got the below email. I think I am good to go now?

@LionOfSound Thats great! You’re good then, yes.

The UX is not where it should be yet. Keeping your identity client-side like that is really a new way and method of doing things. It’ll take some time until it’s really solid. But there’s been great progress, before it was a lot harder.

Thanks again! Are you on Twitter? Would love to make a callout to you and the Blockstack team for the excellent support! :slight_smile:

I got the similar email to the one above. So should I just wait to hear from you guys regarding more information I need to provide, such as my government ID, so that I can take part in the token sale. Thanks in advance!