Fatal error when using docker

I use docker to run a local node.
Here is the algorithm of my actions in order

  1. create folder blockstack
  2. git clone https://github.com/blockstack/stacks-blockchain.git .
  3. I’m create image from dockerfile. docker image build -t blockstack .
  4. Now I tried to run it docker container run -d blockstack , Then I discovered that it was not working docker ps.
  5. I checked the logs and that’s what I found there: “Usage: blockstack-core command [args…]” , so i get arguments from examples and change command
  6. docker container run blockstack blockstack-core testnet, and it’s start node,But the logs still displayed errors

I expected the application to work, but it does not work. Tell me what I was wrong, or is it a program bug?

Hey @Warlock-9000,

What happens if you don’t try and use Docker, and instead just run cargo ... in that folder?

I.e. first run cargo build, which will build everything. And then you can run cargo run --bin blockstack-core testnet

When I tried cargo build, I got this

Is it work for you?

I see a similar issue: https://github.com/blockstack/clarity-js-sdk/issues/58