Failed to query UTXos errors when using Blockstack CLI


I’ve just set up blockstack-core on my Mac (Sierra 10.12.6) following these instructions:

Everything seems to be working fine, can use most of the commands I’ve tried fine, except when I’ve tried the following:

blockstack balance
    "error": "Failed to get balance for 3QRzvxsZ4FffMyCF9KfZWq583Wo6t66dfC"

blockstack register
Calculating total registration costs for
    "error": "Failed to get name costs.  Please try again with `--debug` to see error messages."

blockstack price
    "error": "Failed to get UTXOs for 3Afp3NSuU1dDddhrLhcEwUHTX9m4zh7iPw"

When using the debug flag they all have a similar error:

[2018-06-04 19:01:53,948] [DEBUG] [insight_api:41] (88107.140736516498368) GET
[2018-06-04 19:01:54,300] [ERROR] [insight_api:46] (88107.140736516498368) Failed to query 
[2018-06-04 19:01:54,300] [ERROR] [blockchain:163] (88107.140736516498368) 
HTTPSConnectionPool(host='', port=443): Max retries exceeded with url: /insight- 
api/addr/3QRzvxsZ4FffMyCF9KfZWq583Wo6t66dfC/utxo (Caused by SSLError(SSLError("bad 
handshake: Error([('SSL routines', 'tls_process_server_certificate', 'certificate verify failed')],)",),))

Can anybody let me know what is causing this error? The logs all seem to be fine.
Hopefully it’s just something simple I’ve overlooked.

Thanks in advance,

It looks like you’re using the old CLI as the addresses listed all begin with a “3” instead of a “1”. Have you tried using the new, experimental Blockstack-CLI? You can find it here:


Ahh, I see, I haven’t no but I shall do so now. Thanks for the reply Kitsana, much appreciated. no problem! If you have any issues let me know.



Sorry to hear you’re having trouble! As @Kitsana points out, we have a new CLI in the works that is more reliable. However, for multisig addresses like yours, you’ll have to use the current CLI for the time being.

We had some issues with our default UTXO provider a couple days ago that should be resolved now. Does querying the balance work now?

1 Like

Hi @jude

It works perfectly now, thanks! I will also continue to try out the new CLI as @Kitsana recommended.

Thanks for the reply.

1 Like