Docker: Error response from daemon: Conflict. The container name "/blockstack-api" is already in use by container

Hi~ I am working on Ubuntu 16.04.
I ran “./B…sh start” and opened the Browser sucessfully a few days before. But when I ran “./B…sh start” today, it showed up an error like following. I installed Core but I didn’t run it today.

The question is what should I do? Remove or rename the container? Will that bring any problems to Core?

I find that my question is similiar to, but I can’t understand how he fixed the problem. If someone can explain that it will be really nice.

Thank you !

1 Like

You should be able to run ./launcher stop and then ./launcher start. Does that work for you

Thank you for your reply.
I think I deleted the container, and then some errors appeared like the picture below.

Then I deleted ~/.blockstack/client.ini. After that, I run “sudo ./B…sh start” again, reset some password and defualt settings. But there are still some problems.

What should I do now? Thank you very much!

Hi~ would you like to tell me what should I do now? Thanks a lot

@Myra I’m not seeing any issues in the log you show above. It looks like the containers booted successfully.

What issues are you seeing?