Could not send tokens from Stacks wallet with Trezor


I could not send tokens from Stacks wallet with Trezor model T. I have the latest Trezor bridge and Trezor Firmware. The sign transaction page is permanently stuck in a loading screen.

I tried re-install Stacks wallet, tried to Reset wallet, tried to restart my computer: nothing works. Can you please help me solve this problem?



In early June, I read on reddit that STX token is traded on the TOKOK exchange and I bought some STX there. I can successfully withdraw the tokens to my Trezor + Stacks wallet in June. And I confirm that the available balance in my wallet is not zero, and the associated BTC address has enough BTC to fund the transaction.

After buying STX token, I just left them there. In August, I found out that Blockstack tokensale on Coinlist is live, because I already own some tokens, I did not participate in it. I did, however, joined the telegram channel, and only then did I realize that TOKOK exchange is not recommended by the blockstack team, but it is too late, as I have already bought the tokens.

Now I wish to sell them before the hardfork and before the token release to the Coinlist token buyers. But I found out that I could not send tokens out of my Stacks wallet: the sign transaction page is stuck permanently on loading.

@ yukan @ jude Hi. I read your replies in another support thread and I guess you might be able to help me… I took the liberty to @ you here. Thanks.

This is a screenshot

1 Like

It looks like an issue with the hardware or connection between your computer and the device. Are you connecting the Trezor directly to your computer? If you have another hardware wallet, can you try restoring with the same backup seed phrase as this one and try again?

Thanks for the reply. With the same hardware wallet, I can send BTC/ETH and other tokens without any problem… I am only stuck at Stacks wallet.

Unfortunately I do not have another hareware wallet. @yukan


I will be trying to reproduce this issue, could you tell me what OS you are using windows or Mac?

I will be tracking the bug in issue

mac 10.14.6

I’m interested to see how this resolves. It seems like a fair number of people have bought from this exchange and I’m curious if this problem is shared by more than just you. Hoping it works out for you either way.

Hi all, the year is 2020 and I’m having this exact same problem. I’m attempting to move some stx from my Stacks Wallet+Trezor. When I go to send I’m asked to confirm an OP_RETURN on the trezor, then a small btc txs, then two slightly larger btc txs. When I have confirmed everything, I’m just left with the “Connect your Trezor” screen in the Stacks Wallet and no tx has happened.

best to email [email protected] around this. Thanks!