Core API running, but not valid?

Could use some guidance on what i’m doing wrong to launch the browser.

I can start the blockstack api with “blockstack api start” and check my wallet, names, run “blockstack info” etc. Then I launch the browser using the docker launcher script for 0.20.1, enter my Core API password, and it gives me

Error response from daemon: Conflict. The container name “/blockstack-api” is already in use by container
"d5eca2c6d00bbca528bad69aa9588e7fdd3947b4c8f491e1a10e8d271cc655ce". You have to remove (or rename) that container to be able to reuse that name.

No matter, i can hit localhost:8888 and the browser loads, and the Core API is running, but the console shows “isCoreApiPasswordValid? No!” while “isCoreApiRunning? Yes!”. How can my blockstack api be running, my core api running, but still fails Core auth? Am i confusing multiple auth schemes?

running on ubuntu 16.04, blockstack core 0.17.0, blockstack browser 0.20.1


Did you inadvertently use a passphrase instead of a password when you started the launcher? I did and it caused some bizarre behaviour - see Utter utter utter garbage

that’s the exact behavior i’m seeing, but I’m relatively certain i only used a password. Thanks for the pointer.

You’re welcome. The support guy here seems pretty responsive but I think there’s only one and he’s got a lot of issues to address.

Ok, I think the first problem is that the blockstack browser launcher via Docker launches its own blockstack-api instance, so i was getting a conflict.
Now I can run the script, and get back to the browser page and get the same issue as above (i.e. the CoreApiPassword being incorrect), but now I get a IOError: [Errno 2] No such file or directory: '/home/ju/.virtualchain-spv-headers.dat'
That file is clearly there and in scope.

full error

Traceback (most recent call last):
File “/usr/local/bin/blockstack”, line 52, in
result = run_cli()
File “/usr/local/lib/python2.7/dist-packages/blockstack_client/”, line 515, in run_cli
server_port=blockstack_port, set_global=True
File “/usr/local/lib/python2.7/dist-packages/blockstack_client/”, line 112, in session
File “/usr/local/lib/python2.7/dist-packages/virtualchain/lib/blockchain/bitcoin_blockchain/”, line 444, in init
with open(path, “wb”) as f:
IOError: [Errno 2] No such file or directory: ‘/home/ju/.virtualchain-spv-headers.dat’

I’m no expert, so I may be doing something obviously wrong here.

Hey @jurraca,

You shouldn’t need to be explicitly starting the Core API (i.e. blockstack api start). That’s handled completely within the Linux script from the install. Basically, the Linux script goes and grabs the requisite components as Docker images, bind-mounts ~/.blockstack within the Blockstack Core container, and starts up the Browser and API processes on the correct ports. If all goes well, the ~/.blockstack/client.ini file will be automatically generated, as will the API password and the wallet.json password.

It looks like you have installed Blockstack Core independently of the Browser–i.e. you’re able to use the blockstack tool, and it’s in /usr/local/bin on your computer. Can you try backing up your ~/.blockstack directory, removing it, and instead using the Blockstack launcher shell script to start the browser?

1 Like

Hey @jude thanks for jumping in. Did all that, and when I run the shell script i get prompted to create a password and a wallet, but the error above returns as before. should i remove ~/.blockstack-server as well?

nvm, got it to work. Thanks!

1 Like

Excuse me, I met the same problem as yours, how u fixed it? thank u !

I ran the and I could open a Blockstack Browser a few days before. But when I ran “./ start” today, it responsed me with an error like following
docker: Error response from daemon: Conflict. The container name “/blockstack-api” is already in use by container 06b86fc33c26aa525ad9990431c62b795451fd76cc93772612d60e12eabc6339. You have to remove (or rename) that container to be able to reuse that name…
I downloaded Core but I didn’t run api today. Could u please tell me how u fixed it? Thank you.

When I ran into that, it was because blockstack had previously created containers. run docker ps -a to see what you have running. You can delete or rename the containers using docker rm or docker rename. Blockstack will spin up a new container every time you run Core.

Wow thanks ! I think I deleted the containner but there appeared other errors. I am trying to figure out … thank you very much!