Command not found on Hello World

Hi, newbie here. I’m trying to get started with the hello world tutorial, but I’m running into an error at step 4. When I run the command to get a new stacks 2.0 account, I get the following error:

bash: stx: command not found
malformed JSON string, neither array, object, number, string or atom, at character offset 0 (before “(end of string)”) at /usr/bin/json_pp line 51.

I’m copying the exact command, so I’m not sure what’s wrong. Really appreciate any direction- thank you in advance.

Can you share the link to the tutorial you’re using?

Thank you! This is the tutorial I was following:

I just tried this myself, and I was able to get it to work.
However, I do see where it could be a bit confusing (particularly for a self-confessed newbie, ha).

From the steps, i think you missed a step or two before you got to the stx command, or perhaps there was some error output you missed.

Screenshot 2021-04-22 at 21.36.03

From that screen, where the contract is displayed, i then ran the command stx make_keychain -t | json_pp > cli_keychain.json in the terminal below:

Screenshot 2021-04-22 at 21.40.05

Double check the steps you’re taking here, but I would also recommend filing an issue here: Issues · blockstack/docs · GitHub describing what you saw, and how it can be improved.