Can't sign in with Blockstack on Ubuntu


I’ve installed Blockstack v0.22.1 on Lubuntu 16.04 and every time I try to Sign In it opens a new Chrome window without a link. Also tried with v0.22.0 and the master docker images from , but no luck.

Basically I have the same problem as in this post .
I can confirm that I have the file ~/.local/share/applications/blockstack.desktop and that from CLI xdg-open works correctly.

Made a video of the current behavior.
Every time I reload the page it asks me what storage to use and then it redirects to gaia settings page that it’s blank.

Thanks for your help,

Can you see if this change helps? I think you need to modify the protocol handler:

Thanks for the answer.

I’ve tried the changes in the protocol handler and it didn’t helped.
Then I’ve noticed this:

If you’d like your browser to automatically handle links with the blockstack: protocol specifier, you will need to register a protocol handler with your desktop environment. In Ubuntu/Gnome, this can be done by creating a file

So I’ve installed Ubuntu Gnome to give it a try and Blockstack worked from the first install without having to adjust the protocol handler.

Since it worked on Gnome I thought to try on Ubuntu Mate as well, here it did not worked. At Sign In it opens a new tab correctly with the link, but gives a blank page.

Maybe the protocol handler doesn’t behave the same on different linux desktop environments that are not Gnome.

1 Like