Balance is not updated - GUI on macOS

hello all together,

i have some strange behaviour of my blockstack browser installation running on macOS 10.12.5. First, everything worked find. I could deposit a small amount and start registering a name. Some error messages apeared, but finally the name show up (after some hours). So far, great! Then i deposited another small amount and registered another name (tried to). Now 3 Things happened:
A: only one name shows up under accounts, the other two are sowing only id strings.
B: but in the connected dropbox-app i can see two profile-names, as expected.
C: my wallet sows a balance of 0 BTC instead of the amount, sitting on it regarding also to

So, how can i clean up the situation? Is just installed the software on another machine and restored the backup. Same thing.

Thank you for any advice, tip, hint and help!

Yikes! Sorry about the troubles!

Would you be willing to share your logs?

You can DM a dropbox them to me on the forum or slack or email to larry at