Bad Graphite Bug Discovered (Document Deleted)

Ok so this one goes out to the Graphite devs. I think a major bug happened with Graphite sometime today (the 20th). I had a 2000 word document in my Graphite documents section, an essay/article I had written a couple of days ago. I’m quite glad I have it backed up elsewhere, as I discovered today that it is gone. There is now just an “Untitled” document in it’s place with no text save for the words “Undefined”. Here are some pictures to show what I mean:

Here’s the sorta freaky thing though… I shared a read-only link with a friend of that document, and I just went back and checked and that link will still open the read-only version of it. Here’s a picture showing that:

Heck, here’s the link to it as well! It should still open correctly, as least as of me typing this.

Hopefully the Graphite devs can solve this issue so it doesn’t happen again. I’d have been really upset if I didn’t have that document backed up elsewhere!

(P.S. If someone wants to read the finished version of that article, let me know and I’ll pass on a link to it! I even mentioned Blockstack in it! :slight_smile: )

Not a Graphite dev, but it looks like the document exists:
However, it’s encrypted with your app private key. Will let @jehunter5811 confirm.

(I got the above URL by (1) looking up your profile, (2) finding your Gaia hub URL for Graphite Docs, and (3) constructing the //documents/1539751587423.json path from the link you provided.)

1 Like

Thanks, Jude! I’ve been out of town so sorry for the delay in getting back to you.

We can debug here in the forum or via email, just let me know what you prefer.

1 Like

Yeah, I know it exists in some form, as the read-only link will still open. I’m fixing to get with jehunter to see if we can fix it! Thanks for finding that info though! :slight_smile:

No worries!

It’s however you want to debug it! Which ever is easier with you is fine with me! No matter what though, the answers should be posted here afterwards to help others who might encounter this. :face_with_monocle:

Let me know which way you wanna debug it!

Let’s keep the convo here to keep it open to the public. Though this should ABSOLUTELY not be a thing any one else has to debug. I am not sure how your documents got into this state, but here is my assumption:

I think the index file (which is used to display your list of documents on the main /documents page) got broken. I don’t think anything happened to your actual file (per your and Jude’s observations).

But let’s test that theory. Can you do to

Let me know if your original document loads up for you there. If so, the system is not designed to re-create the doc in the index file (since the index shouldn’t have broke in the first place). So the quickest fix would be to copy all of your file, create a new doc and paste it in. Let me know how that goes.

1 Like

Ok, yes! That fixed it! That loaded the document, and has now fixed it in Graphite as well. I just logged back into it normally after doing that, and it’s now fixed! Any idea how that index file became broken to begin with?

Also, I just saw the updates y’all did to the site! Looks really good and much more professional! :smiley:
(You still need to add in a sans-serif font though! :stuck_out_tongue_winking_eye: )

1 Like

I pored over the code for the index file and cannot find anything that could have caused that issue unless there was an interruption in the connection when the index file was being updated. I doubt that was the case, but if it was, there’s good news. Graphite is moving toward some significant offline-first improvements. So even if you lose connection, all data will be saved.

And thanks so much for the kind words on the improved menu bar! Additional fonts are coming (possibly this week). Really appreciate you using Graphite!

1 Like

Huh… Yeah, that error happened sometime after I had finished editing the document. The only thing I had done within a day of that happening was enable a read-only link to it for a friend to look at it with. If there’s anything on my end you want me to try and do to debug it, let me know! (I’m a programmer/web designer, so I know that it’s 5% creation 95% debugging! :laughing: ) The offline improvements sound awesome though!

And hey, I’m always happy to thank someone who makes a fantastic product/service I love! If I may suggest a few fonts to consider using for sans-serif, I’d suggest either OpenSans or Roboto. I’m a Mac guy, so Helvetica is a font very close to my heart! Roboto especially is exceptionally close in style to Helvetica, and might make a very good looking font! :smiley:
Oh, and one more suggestion! Maybe make it so you can download a file that contains the Markdown formatting (I assume that’s what you’re using, but I could be wrong)? Since the platforms I upload to support Markdown, such as SteemIt and Minds, having that Markdown code available would make it super easy to just move that document right over to those platforms! (You could also add an export to SteemIt/Minds option, but I know that’d probably be a lot more work! :stuck_out_tongue_winking_eye: )

1 Like

The Graphite editor is actually all HTML under the hood. But you and @larry have now mentioned markdown, so I’m looking into a way to allow users to toggle between writing in Markdown and in the standard WYSIWYG editor.


That’s awesome! I honestly figured it was Markdown the way it was setup, but that’s really cool you actually built a WYSIWYG editor in HTML! I think both options would be greatly beneficial though, if just for exporting reasons! :sunglasses:

Oh, one more small suggestion! When you click on the app icon in the Blockstack browser, instead of taking users to the main site, take them right to the sign-in/dashboard for Graphite instead! :slight_smile:

100% agree. That’s just laziness on my part. Been meaning to submit a pull request to Blockstack to update the app icon and update the link. :grimacing:

1 Like

Great to see the open Graphite debugging going on here.