App stalls after authentication

I’ve hit this a few times in 2 apps which makes me think I’ve done something on my end that I can’t rectify.

Twice I’ve tried to authenticate into an app (ToDo and now Coins) where after I accept the authentication, and the setup process stalls. After a few minutes I just close the browser.

I’ve tested this in Firefox and Safari. I believe Firefox plugins are interfering with the signup process and that then gets apps in a bad state. In both cases, I tried to authenticate in Firefox with HTTPS Everywhere & Privacy Badger running. These are interfering with the connections and getting the apps in a bad state.

At this point I tried the following without any resolution:

  • Disable the extensions, close the browser, open it back up and try again (only for it to spin again)
  • Try in another browser (going from Firefox to Safari)

Any ideas on how to resolve? If it has happened to me, I’m guessing it is happening to others and I’m hitting some edge case that we need a solution around.

Keep up the good work!