App asking for social media accounts; already linked

The token sale app is saying I need to come here for help as it is not recognizing the social media accounts that I have registered.

“You’re Almost There
To proceed, you’ll need to verify at least one social account for this Blockstack ID.
If you have already done so, ask for help on our forums or at our support desk.”

Anyone know how to fix this?

Hey @arturkel, sorry to hear you’re having trouble!

We released a new version of the browser that should address this (v0.20.1). Can you try going to the downloads page and installing the latest one? If it still doesn’t work, can you post your ID address, so I can go manually check to see what the sign-up servers are seeing when you try go sign in? Thanks!

That worked. I had to actually go in and re-verify my accounts after I installed the new browser though. Thanks Jude!

1 Like


I have installed the browser just today on my Ubuntu machine but it keeps telling me
"To proceed, you’ll need to verify at least one social account for this Blockstack ID."

I’m a bit confused, and don’t know what to do?

Help please?

Hey @1A8YKWw95wQz8dJW2izF,

If you want to participate in the token sale, you need to add at least one “social proof” to prove that you’re a human and not a bot :slight_smile: This is only necessary if you want to participate in the sale. If you just want to use Blockstack apps, then no further action is necessary.

The social proofs work by posting a public message in a social media service account that you own, like a Twitter account or a Facebook account. To add a social proof from within the Blockstack browser, click in the “IDs” button in the top-right, and then fill in at least one of the social media fields. We have a list of detailed walkthroughs for the trickier ones here

1 Like

Hi @jude, thanks for the quick reply. I did do the social proof thing; or at least I think I did. But it still prompts me to do the social proof thing.

Hi! If you give the full ID, jude or anyone else will be able to check how your profile looks.

Hi everything works (How do I delete this comment?)