All short IDs have status already taken

Hi All

I am just trying to register a name, this used to work.
Now if I try say it says this ID is already taken.
Long strings with more than 30 char works. Anyone else facing this?

I already tried restarting from fresh after restoring keychain, same result.

How do you get a log dump on a linux box (Fedora) ?
Thank you

oh no. But there are sub-domains.

I’m seeing it as available:

Are you seeing anything strange in the JS console? In chrome/chromium, you can get to this with Ctrl+Shift+I.

1 Like

I was getting this error late last night as well. It doesn’t seem to be happening anymore, however. At the time I noticed that was stuck loading as well.

Our public nodes had a little bit of downtime last night that got fixed (the load-balancer died and there was a bug in the monitoring tool that caused it to not notice). Sorry about that! We’re working on fixing this.

Thanks for the tip, see below output of console. It seems connectivity issue but I don’t think it’s on your side.

2018-04-07T23:00:18.582+0100 TRACE profiles/components/registration/RegistrationSearchView.js: showSearchBox
2018-04-07T23:00:38.050+0100 TRACE profiles/components/registration/RegistrationSearchView.js: search
2018-04-07T23:00:38.052+0100 DEBUG profiles/components/registration/RegistrationSearchView.js: search: user is searching for fffsfsfsffeqwe3442424rrwrwr
2018-04-07T23:00:38.060+0100 DEBUG profiles/store/availability/actions.js: checkNameAvailabilityAndPrice:
2018-04-07T23:00:38.068+0100 TRACE profiles/components/registration/RegistrationSearchView.js: componentWillReceiveProps
2018-04-07T23:00:38.088+0100 ERROR utils/name-utils.js: isNameAvailable [TypeError: NetworkError when attempting to fetch resource.]
2018-04-07T23:00:38.089+0100 ERROR profiles/store/availability/actions.js: checkNameAvailabilityAndPrice: isNameAvailable: error [TypeError: NetworkError when attempting to fetch resource.]
2018-04-07T23:00:38.097+0100 TRACE profiles/components/registration/RegistrationSearchView.js: componentWillReceiveProps

as it turns out API end point was not able to communicate with blockstack-core

 curl http://localhost:6270/v1/names/
{"error": "Failed to connect to backend"}

This was fixed after restarting blockstack api.
curl http://localhost:6270/v1/names/
{“status”: “registered”, “zonefile”: "$ORIGIN\n$TTL 3600\n_http._tcp URI 10 1 ""\n", “expire_block”: 599312, “blockchain”: “bitcoin”, “last_txid”: “be19a8e97d97da87ac0160e20c48c07d122411f291281152039d14e76340d136”, “address”: “13sPExcKGvstnDcvqEx1N98pzWm9N3SDcM”, “zonefile_hash”: “e318f72fa12dc68b2da48c15bc1e33c065b1a381”}

Now have a different issue when trying to register a name, console message:

2018-04-08T22:27:43.287+0100 ERROR profiles/store/registration/actions.js: registerName: error submitting name registration [TypeError: utxoList is undefined] getNetworkedUTXOs/<@http://localhost:8888/js/main.js:52005:9

Either way, I think this is also a bad error text then? Probably should say that the Core node couldn’t be reached instead of taken :slight_smile:

1 Like

Yes just bad error text. Using the browser console helps a lot to figure out what’s wrong. I wish had known this from the start.
Anyway I’m up and running now. My ID is I stopped using the script for docker install on linux, just too painful. Install from source works best for me.