Adding contacts in Graphite

Dear Blockstack community,

Been playing and working with Graphite for some time now and this weekend been trying to get it working for collaborating on a text document.
Somehow I’m not able to add contacts, neither by searching for username or ID.
Tried looking for my friends ID or username, nothing comes up; same when I run my ID on her machine.

We both use a Blockstack local instance and Brave browser (current version) on OSX (current version).

Anyone have had success with adding contacts in Graphite?

Any help or ideas are much appreciated!


Hey Dan,

I’m the creator of Graphite. Are searching only by username? The search api I’m using seems not to hit on username well anymore, but I’m not sure why. I need to do some testing, but it picks up the profile name or other profile info pretty well.

If you’re willing to share the ID you’re searching for, I can take a look at what’s going.


Hello Justin!

thanks for taking your time to answer me!

The ID is the following:

Also searching for username doesn’t bring up anything.
Could it have to do with the local clients not syncing with the blockchain?..


Thanks! I need some better messaging in the interface, but temp IDs do not have zonefiles and therefore cannot utilize the collaboration features of Graphite. That address does not have a username or a zonefile based on my query here:

Therefore, it is not available to find and add as a contact.

1 Like

Ok so I need to register for a user name to access collaboration features, correct?

That’s correct, but it may be smart to hold off a week or so. It looks like Blockstack is about to release the newest version of the Browser, which should have free name registrations.

1 Like

Amazing, thanks for the valuable hint (:slight_smile:

1 Like


I think it should be explicit on the web site that the collaborative features need a registered ID.

1 Like

Hi, I’m also not able to add collaborators in Graphite. Nothing happens when I type on ID in the search field. The person with whom I collaborating has the same issue. Is it relating to having new accounts? Neither of us used real email addresses, for privacy, in case that’s related. I tried the user name I choose with by blockstack ID. I tried with and without the “.id.blockstack” appended. Tangentially, I also couldn’t login into this forum with my blockstack ID and password; I kept getting looped back to empty login fields.