Accounts are staying unverified

I’ve now tried to verify each of my accounts several times following the instructions posted for each site, and they remain unverified. I’ve also tried Ctrl + F5 to reset the browser and it still does not seem to be working. What should my next steps be to try to fix this?

Separately, I’ve tried to add multiple photos to my profile. Every time I click change photo then click a file, nothing happens. Are there certain specifications the photos have to be to work?

My Blockstack ID is ID-1824ZBU8h7sb8kzxkSdcUtkgCEosXcJRWZ

Here is a screenshot of what it looks like at this point:

I’ve been following the Blockstack project for nearly a year now and have been very excited about it, so I really hope I can actually be involved in the token sale.

Thanks in advance for the help!

What OS are you on?

Do you show any errors in your console? (press F12, errors should be red, if so share the screenshot)

Did you already have a prior version of the Blockstack-Browser installed on this machine? might be experiencing a conflict with an older version.

Looks like you are experiencing what happened to me after I upgraded, I was able to sort though it and can likely lend a hand here just need more info (above)


I’m using Windows 10

I do not see any errors in the console:

I did have a previous version from several weeks ago and had purchased an ID, which is no longer showing in the current version (along with ~$100 in bitcoin). I’ve tried uninstalling and reinstalling a few different times, I know have v0.20.1 installed though.

Is there any way to check if there are any conflicts with previous versions?

What is your default browser?
Have you tried clearing your default browsers cache?
Did you use the msi installer?

I had a similar problem because I had version 0.17 previously installed which used a docker container to facilitate core api, and when I upgrade to the latest verion, using the windows uninstaller didn’t fully remove everything that it needed to (presumably),. The latest version doesn’t speak to localhost at the for core api calls, but rather until the windows version gets updated to run core natively. I have a feeling you aren’t communicating to that end point yet like I wasn’t.

You might want to uninstall and then delete the whole Blockstack Browser directory in Program files.
Be sure to Backup your Keychain if you have any deposited BTC or registered names before hand though so don’t lose them. I had to do this and also clear my localStorage in my browser to start over at the “Get Started” page before i could get the latest version to verify.

Hope this helps, happy Blockstacking!


Thanks for the help.

My default is Microsoft Edge on this computer. Would it work better to use a different browser?

I downloaded the msi file from GitHub here:

I uninstalled and removed all files from the Blockstack directory in my files and reinstalled and seem to still be having the issues. I also tried clearing my browser’s cache.

I do have a few errors in the console now though:

Ok ya it looks like your blockstack browser is still attempting to use: localhost:6270 as the path for API calls even though it should be using instead (this is a temporary thing mind you) .

The only difference between what you are doing and what I was doing so far that I can tell is that I use chrome as my default browser.

also did you remove the .blockstack folder from %APPDATA% (pretty sure that was its location nways ?
seems like I had to do that too if my memory is correct.

Tagging @aaron … to see his thoughts on this since he helped me get past the hurdle when I encountered it myself.


Thank you, I think I finally have things mostly figured out.

I changed my default browser to chrome. I uninstalled Blockstack and deleted the Blockstack folder from %APPDATA%. Then reinstalled v0.20.1, and my accounts finally verified.

Two small lingering issues I could use some help with though.

  1. I still do not seem to be able to upload a photo, any advice there?

  2. I purchased the username noahkirsch a few weeks ago, and I am not sure how I can get that back and associate it with this new account that now is connected with my verified accounts.

Thanks again for your help, it is much appreciated!

Actually, I was able to upload a photo now. The first one I tried must have been too large a file.