According to my local Blockstack Browser, my accounts are not verified

If I go to it looks like I have a ‘social level’ of 2 with my Twitter and GitHub accounts confirmed.

If I then go to localhost:8888 (the local browser) it looks like I have a ‘social level’ of 0.

What’s causing this? I’ve tried to reset the browser multiple times but nothing changes, I also deleted my tweet and tweeted it again, but same thing. Any idea about how to fix this?

My Blockstack id is

Are you sure you’re correctly logged in to the local browser? Is your owner address 1MCDSnUM6RKgNVqoG2bBRp6Z6BveM39wsw there?

Your profile looks correct. So there must be something with your local setup. Especially since also works.

You didn’t say what OS you’re using and how you installed Blockstack, also you should say what version it is.

1 Like

Thanks for your reply! :slight_smile:

That’s my address on both the local browser and on and I’m pretty sure that I’m signed in correctly, everything else is working and I reset the browser multiple times.

Right now I’m on Ubuntu and I just downloaded and ran the Bash file, I’m using version 0.31.1. I also have a Windows laptop and where I think I’m running version 0.31.0, on Windows I downloaded and ran the .msi file.

So you should wait until someone else can come and help.

It does not look like the browser does the verifications itself in JS. calls and it returns validation results. So locally, you should check devtools to see what it’s trying to call. You will probably have to run that proof-checking service.

I wonder why there’s a validate endpoint now, I thought the plan was for the check to be done in Javascript, just using a CORS proxy so it would actually be possible to read the data.

1 Like

I just want to add that on my Ubuntu desktop I’m now using version 0.31.0.

On my Ubuntu computer I installed Blockstack this way: (Forgot to be specific before)

  1. Download the .sh file from
  2. Open the terminal and navigate to my Downloads folder
  3. Type sudo bash -f ./ to see how I should install it
  4. Type sudo bash -f ./ pull
  5. Type sudo bash -f ./ install-protocol-handler
  6. Type sudo bash -f ./ start

Then I reset the browser to make sure that the newer version of the browser didn’t leave something behind that would cause error to happen again:
I went to localhost:8888 and opened the console (Ctrl+Shift+K) and typed localStorage.clear().

Still not working, I get the same result as before.