Reset Browser

  1. Cear local storage:

Go to “view” -> developer -> javascript console

Click on javascript console, scroll to the very bottom, then at the last field type localStorage.clear()

Refresh the page.

  1. Hard Browser Refresh:

Please see:

NB! You have to actually go to the Blockstack start page, and THEN clear localStorage. You can’t do it on any random page.

Ah okay, so must be done by the “home” page? Thanks for clarifying!!

1 Like

I’ve cleared storage, restarted, created a new gist, but nothing happens. When I click “Verify” the window just disappear with no message (not even an error) and no verification. No error in the console either.

Note: it was verified before, but today once I updated the software the profile lost it (together with name, bio, and avatar).

Hey there,

Sorry that this is happening. Can you please share your Blockstack ID or send a screenshot of the post?
Please check out How Can I Verify My Github Account?


This is valid.

$ ./validateProof.js 1AvvoCDvKjrAbumDq8xCLUjBEH2jRRwyCe
Validate github (
[ { service: 'github',
    proof_url: '',
    identifier: 'folletto',
    valid: true } ]

So what is probably happening is that your browser can’t itself verify that. If you have no errors in your console whatsoever, open it and then reload, and do your thing, it can sound like it isn’t working as it should. Or it would be a silent local-server-side problem. You are probably running two services depending on OS and install, a blockstack one, and a CORS proxy. If the CORS proxy doesn’t work, then the verification won’t work.

Actually, it would be technically better to run an external CORS proxy, but I see that the communication around that could be tricky.

Hi! I tried again, and now it worked. No idea what changed, it didn’t even update the Gist nor the local stack.

Thank you for the check! :slight_smile:

Did that and then it asked to sign up or restore keychain (this seems to happen at browser updates). Restored keychain and now it appears that none of the information is there anymore re: social level… appears wallet is same - must be taking some time to gather the information…?

also when trying to go to todo app - says must setup blockstack again…

Now, after closing the blockstack browser and opening again it asks to pick default storage (done on the restore) but it keeps asking? Just an FYI

I also cant verify my fb
I’ve alredy made Hard Browser Refresh, but it didn’t helped.