Issue with Firefox Sign in?

I just got an email from a user of saying

When I click on green sign in button nothing happens. Just presses then nothing. I am using latest Firefox 64 and even tried with adblocker turned off.

I tried it on my computer as well and since I use local Blockstack Browser, Sign in button opened the link in the default browser (which is Chrome) and then redirected it back to Chrome. So, trying to login in Firefox actually logged me in, in Chrome.

I searched the forum and it looks like there were some issues with FF in the past. But maybe this bug hasn’t been reported yet so I am posting this.


I’m actually having the same issue, except that in my case the default browser is Firefox, so really nothing ends up happening when I click on the sign in button.

On the Firefox console, I see the following log entries.


@aviaryan123 @siddhantgoel Please file issues on the Github repo here:

Unfortunately, there are several known issues with Firefox. You can search for Firefox in particular.

There are also some discussions in the Forum.

The proper approach for solving these issues is something we are actively working to resolve. We would welcome your input.

1 Like

Thanks for the reply, @moxiegirl. I just opened the Github issue.
I will see what I can do to help.