Confused about a Blockstack ID transfer

Earlier this week, I transferred my Blockstack ID ( out of and via Onename to my Blockstack browser ID address (1k1BfmwUCxVcgnCeFZ3EzVGot1QTLdopF).

I checked the explorer, and it confirmed that pthomasgarcia is owned by my browser ID address: But, when checking my ID in Blockstack browser (version 0.21.0), it’s at 0%. No username.

I noticed when I check the username in the explorer, it alerts that it’s “Loading zone file…,” but never does. Is there anything I have to do on my end to complete the process?

Also, I contacted Onename. They recommended a hard refresh of the browser and/or restore the profile from the keychain phrase. I did both but had no success with either.

Much appreciated.

Hey @pthomasgarcia, sorry you’re having trouble!

The “loading zone file…” message may be due to the fact that the explorer is under load. I confirmed that your zone file is indeed available in the Blockstack Atlas network, and your profile was successfully transferred to Gaia. Just need to figure out why the browser is misbehaving for you :confused:

We discovered earlier today that in some cases, it can take a few minutes for the browser to load all of its data. We’re still investigating why this is, but if you leave your browser tab open for ~5 minutes on your identity page, does anything change on its own?

Hi @jude,

Thanks for responding. I tried leaving the browser tab open and active for 10 minutes or so and had it open in the background for a number of hours, but nothing happened. So, normally after a name transfer, the browser loads all the data itself?

I don’t know if this has anything to do with it, but if I run blockstack lookup in terminal, it returns: “error”: “Failure in parsing and fetching profile”.

I’ll also add that when I click on the ADD A USERNAME button, I’m unable to fill out the username field.

This solved it for me:

Thanks, @larry and @jude