[Bug] It takes forever to login to Hermes

i tried using Hermes but it just loads forever when i try to login with blockstack there are a few other apps i have tried using that i also had the same problem with

Sorry to here that, if you can provide some more information, we may be able to figure out what’s wrong and fix the issue.

What browser are you using? Where in the process does is it stop? (in the Blockstack login approval screen? or while the authentication flow is still in the application itself?) Do you see any errors or messages in your browser’s console log?

im using firefox with the desktop blockstack browser and im using windows 10 as my OS

now it is saying the page is down

It looks like the Blockstack Browser isn’t running. Can you start the application?

yes and here is the console log from my web browser
TypeError: asm.js type error: module import needs initializer main.js:258088:10
TypeError: asm.js type error: asm.js modules takes at most 3 argument main.js:258481:11
TypeError: asm.js type error: asm.js modules takes at most 3 argument main.js:258510:11
persted data exists:
Object { account: {…}, auth: {…}, apps: {…}, profiles: {…}, sanity: {…}, settings: {…} }
main.js:8748:13
no computed states main.js:8767:13
legacystore null main.js:8807:3
2018-07-31T10:12:50.805-0400 INFO utils/logging-utils.js: Logging system enabled main.js:270681:5
2018-07-31T10:12:50.805-0400 INFO utils/logging-utils.js: Log server: disabled main.js:270681:5
2018-07-31T10:12:50.806-0400 TRACE index.js: NODE_ENV is not production main.js:270681:5
2018-07-31T10:12:50.806-0400 DEBUG index.js: Enabling React devtools main.js:270681:5
2018-07-31T10:12:50.812-0400 DEBUG App.js: EXISTING_VERSION: 14; CURRENT_VERSION:
14 main.js:270681:5
2018-07-31T10:12:50.813-0400 TRACE App.js: componentWillMount main.js:270681:5
2018-07-31T10:12:50.813-0400 DEBUG App.js: Core-less build. Pretending to have a valid core connection. main.js:270681:5
2018-07-31T10:12:50.921-0400 DEBUG auth/components/AuthModal.js: componentWillReceiveProps: no app domain or no core session token main.js:270681:5
2018-07-31T10:12:51.041-0400 DEBUG auth/components/AuthModal.js: componentWillReceiveProps: no app domain or no core session token main.js:270681:5
2018-07-31T10:12:53.364-0400 DEBUG auth/components/AuthModal.js: login: name is not visible on the network. main.js:270681:5
2018-07-31T10:12:53.364-0400 TRACE auth/components/util.js: validateScopes main.js:270681:5
2018-07-31T10:12:53.371-0400 TRACE auth/components/AuthModal.js: login(): app can communicate directly with gaiahub, not setting up core. main.js:270681:5
2018-07-31T10:12:53.376-0400 TRACE auth/store/auth.js: noCoreSessionToken(): dispatched main.js:270681:5
2018-07-31T10:12:53.377-0400 DEBUG auth/components/AuthModal.js: componentWillReceiveProps: no core session token expected main.js:270681:5
2018-07-31T10:12:53.377-0400 TRACE auth/components/AuthModal.js: componentWillReceiveProps main.js:270681:5
2018-07-31T10:12:53.377-0400 DEBUG auth/components/AuthModal.js: componentWillReceiveProps: received no coreSessionToken main.js:270681:5
2018-07-31T10:12:53.639-0400 DEBUG utils/profile-utils.js: Found valid profile at https://gaia.blockstack.org/hub/126oF964T27KiVgrQPeWV3UfR651yoPqge/profile.json main.js:270681:5
2018-07-31T10:12:53.640-0400 DEBUG auth/components/AuthModal.js: componentWillReceiveProps: storage is not connected. Doing nothing. main.js:270681:5

blockstack browser: 0.31.0
blockstack": “^18.0.2”,

Suddenly run into spookily similar issue with Chrome suddenly today after upgrading blockstack.js from 18.0.0 to 18.0.2.

Toggling default browser shows Firefox is still working. Blockstack Browser is running.

Screen shots below show it hangs in the same place - AuthModal.js.

  1. Chrome

  2. Firefox.

I’ve had this issue intermittently before now but it seems pretty persistent as I’ve tried the usual clear down and restart tactic.

Hey folks, we just merged in a change that should resolve this issue for everyone going forward (here, if you’re interested.) Expect a new release by early next week at the latest with that change included. Sorry for the temporary inconvenience.

Until that ships, a quick way to fix this issue is to reset your browser from the settings menu and restore your Blockstack ID. This will fix your connection to the storage system. Just make sure you’ve backed up your secret recovery key or magic recovery code + password first!

1 Like

Just tried dropping back to 18.0.0 but wasn’t that.

If I reload the signin page I see bunch of 403 on port 8333 - see screenshot…

Is it possible this is coming from new version of chrome? Wondering as I noticed they have been releasing CORS bug fixes in recent versions and the signin page loads from 8888 but calls 8333 on localhost?

See…
https://bugs.chromium.org/p/chromium/issues/list?q=component:Blink>SecurityFeature
https://www.chromestatus.com/feature/5629709824032768

Thanks @wbobeirne - will give that a go!